none
Tiempo de conexión Team Foundation Server Express 2013 /// Timeout Team Foundation Server Express 2013 RRS feed

  • Pregunta

  • Buenas tardes,

    He instalado Visual Studio Team Foundation Server Express 2013 con la configuración por defecto y con una Base de Datos Express que te crea automáticamente.

    Para acceder en local usamos la url http://localhost:8080/tfs, entonces nos pide credenciales de acceso, las ingresamos y tarda en conectarse entre 20 y 30 segundos, lo cual me aprece una barbaridad.

    Además, cuando está la sesión inactiva por unos minutos (por ejemplo 20 minutos), si intentas moverte por la web del TFS tarda en cargar otros 20-30 segundos, luego funciona fluido mientras lo estás usando, pero si dejas de usarlo de nuevo cuando vuelves hace lo mismo.

    Creo que esto no debe ser así, ya que podemos tener abierta la web del TFS durante horas pero no estamos constantemente moviéndonos por ella, entonces cuando volvemos tarda en conectar y resulta bastante poco eficiente. Si conectamos a través de la red en lugar de en local, hace exactamente lo mismo.

    Me gustaría saber si hay que hacer algo o si hay que activar alguna función especial en el TFS para evitar que esto ocurra.

    Muchas gracias.

    Un saludo.

    -----------------------------------------------------------------------------------------------------------

    Good afternoon, 

    I installed Visual Studio Team Foundation Server 2013 Express with the default settings and a Database Express automatically creates you. 



    To access local use the url http: // localhost: 8080 / tfs, then asks us access credentials, the log we enter and takes between 20 and 30 seconds, which aprece me a lot. 


    Furthermore, when the idle session for a few minutes (eg 20 minutes), if you try to move around the website TFS takes to load another 20-30 seconds, then works fluid while you're using, but if you stop using it again when does the same again. 



    I think this must not, and we can have the website open for hours but not TFS are constantly moving around it, then when we return takes to connect and is quite inefficient. If you connect via the network rather than locally, does exactly the same. 



    I wonder if something must be done or some special function whether to enable the TFS to prevent this from happening. 

    Thank you very much. 
    A greeting.

    jueves, 16 de octubre de 2014 10:46

Todas las respuestas

  • Hola,

    En efecto, es una barbaridad que tome tanto tiempo. Usualmente tarda un par de segundos en hacer la conexión y permitir que lo uses. Un par de preguntas: Estas conectandote al proyecto via web o por medio de Visual Studio?

    Estas velocidades realmente dependen de la topología que tengas y de las capacidades del servidor. Por lo que entiendo el deploy lo hiciste en un solo servidor e imagino que al ser un nuevo deployment realmente no tienes mucha carga de usuarios en él.

    Como idea al momento se me ocurre que puede ser un problema con la red pero necesitariamos mas evidencia para tener esa conclusión.

    Saludos!,

    Luis


    If the post was helpful to the solution of your problem or question please dont forget to flag it as 'Useful'

    miércoles, 12 de noviembre de 2014 18:16
  • Hola Luis,

    Nos conectamos al proyecto vía web sí. El servidor tiene unas velocidades de subida muy altas (200mb o así) y nos conectamos desde redes con unos 50mb de red, así que supongo que la red no debe ser. Una vez hace la primera conexión después de ese tiempo cualquier cosa la hace astante rápido la verdad, hat que vuelve a fallar y está todo ese tiempo y así sucesivamente jaja.

    Tampoco hay muchas carga de usuarios en él, apenas 1 o 2 personas temporalmente.

    El propio servidor en local al conectar también tarda todo ese tiempo en la primera conexión, parece que es de algo de TFS pero no sabría decir...

    Gracias. Un saludo.

    jueves, 13 de noviembre de 2014 11:43
  • El TFS sufre mucho en rendimiento cuando la SQL sobre el que se basa se queda corto de memoria. Puede ser un primer paso el comprobar que la SQL está limitada en su crecimiento para que no devore toda la RAM.
    jueves, 13 de noviembre de 2014 20:25
  • Dependiendo de las capacidades del servidor donde hayas montado tu ambiente de TFS puede tardar en mayor o menor medida, ahora que he revisado con un compañero si tarda en ocasiones más tiempo en cargar. También por default la sesión expira después de un tiempo determinado de no usar, la sesión caduca y se debe de hacer el proceso completo nuevamente. 

    Una prueba que podriamos hacer sería antes de iniciar la conexión a tu proyecto desde Team Web Access es descargar un web debugger (haz una busqueda de 'web debugging proxy') y dejas haciendo la captura mientras replicas el problema reportado. Esa captura hay que revisarla y revisar si hay un cuello de botella o algo similar, esto nos debe dar una idea mas clara, y ya posteriormente lo ideal seria ejecutar una captura de red con NetMon desde el servidor y desde el cliente para revisar los tiempos.

    Sobre el comentario de Juan Quijano también esta en lo correcto, SQL Server por diseño de producto se comporta como desbordamiento de memoria, así que si no lo estamos revisando constantemente consume toda la memoria que logre encontrar disponible.

    Si haces la captura copia los resultados aquí para que podamos echarle un ojo.

    Saludos!

    Luis


    If the post was helpful to the solution of your problem or question please dont forget to flag it as 'Useful'

    jueves, 13 de noviembre de 2014 22:46