none
Error Debug VS 2017 RRS feed

  • Pregunta

  • Buenos días, 

    Llevo unos días con un problema a la hora de ejecutar una aplicación de tipo background de universal windows en VS2017 c#.

    La creo sin problemas e introduzco el código, pero al hacer el debug en local, me compila correctamente y a la hora de ejecutar la aplicación me muestra el siguiente mensaje en una ventana emergente, no de tipo compilación:

    "No se puede activar la aplicación de la Tienda Windows "BackgroundApplication1-uwp_6ekkpgo1yp1g0!App". Error de solicitud de activación:'La directiva del grupo bloquea a este programa. Para obtener mas información, póngase en contacto con el administrador del sistema'. Consulta la ayuda para obtener información sobre cómo solucionar el problema."

    La ayuda me remite a la siguiente url: https://docs.microsoft.com/es-es/previous-versions/hh972445(v=vs.140)

    Y si busco en el visor de evento, el error que tengo del tipo que indican es:

    "No se pudo realizar la activación de 4c8dffa8-88d3-4bed-86fd-f02099ded0e9_6ekkpgp1yp1g0!App. Código de error: Unknown HResult Error code: 0x80040906. Fase de activación: COM ActivateExtension"

    ¿Alguien me puede indicar que es lo que puede estar pasando? lo que me tiene desconcertado es que si creo por ejemplo un proyecto de tipo universal windows en blanco, la aplicación compila y arranca correctamente. 

    He probado en dos ordenadores distintos y el problema es el mismo en ambos, con la app de tipo background da el mismo error y con app en blanco arranca sin problemas. He activado el modo desarrollador y todo sigue igual. Ademas, es que no entiendo el motivo por el que tiene que registrarlo en la tienda de windows si no he enlazado nada, es mas, si accedo a la opción de la tienda windows en ambos proyecto me da error, por lo que entiendo que no tiene que ser nada de eso.

    A la hora de crear el poyecto tampoco he modificado nada, es decir, lo creo, lo ejecuto y me da el error, por lo que también descarto que sea un problema de codigo o cambios que he realizado.

    Muchas gracias!

    miércoles, 30 de enero de 2019 6:44

Todas las respuestas

  • hola

    Estas usando en tu desarollo alguna libreria de terceros, algo que sea COM, como ser las librerias de Office?

    el mensaje indica qe no puede crear la instancia de una libreria COM que estas referenciando, quizas debas reemplazarla

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    miércoles, 30 de enero de 2019 10:31
  • Hola!

    no, no estoy usando nada raro. Si es verdad que ahora he ejecutado el visor de eventos y no veo error, pero la ventana me sigue saliendo, por lo que ya no sabría decirte si el error que he puesto es de otra aplicación :( ahora mismo ya solo me salen los de ayer y no puede confirmarlo.

    El problema es que si creo el proyecto background, y sin modificar ni cambiar ningún parámetro, únicamente cambiando "ARM" por "x64" o "x86" y "Equipo Local" para hacer el debug, me sale la ventana emergente que os comento.

    miércoles, 30 de enero de 2019 13:18