none
Autonumérico en SQL Azure da saltos de hasta 1000 número RRS feed

  • Pregunta

  • Hola, 

    Tengo una base de datos en SQL Azure con una tabla de Clientes, la misma tiene el campo ID como Identidad y clave principal. La inserción de campos en esa tabla la realizo mediante un "INSERT INTO......" y no tengo problemas. En principio las veces que tengo que insertar registros no inserto más de 15 o 20 y siempre crea el campo ID correctamente aumentando en 1, sin embargo, hasta en tres ocasiones recientemente y sin determinar en el momento en el que ha ocurrido, ni el como, ni el porque, dicho campo ID me ha dado un salto cuantitativo de hasta 1000 números, vamos la primera vez iba por un 250 y el siguiente registro empezó por el 1287 apróximadamente. 

    La verdad es que por mas cuelgas que le doy no llego a comprender el motivo por el que hace eso, podría pensar, como he leído por aquí que si se cancela un proceso de inserción de registros el Identity ya se queda creado pero en ese caso no debería de haber un salto de mas de 20 números y no de más de 1000.

    La verdad es que me está volviendo loco el tema y no comprendo el motivo. Saben ustedes algún motivo por el que me pueda estar pasando esto?

    Gracias.

    martes, 18 de febrero de 2014 20:40

Todas las respuestas

  • Para ser mas exactos los saltos que me han ocurrido han sido del 914 al 1904, y del 2184 al 3184 y eso me resulta mucho mas raro de comprender por los números que provocan los saltos.
    martes, 18 de febrero de 2014 20:48
  • Hola,

    Es un gusto que postees en el foro. Tu consulta parece algo compleja, espero este link te ayude a encontrar la respuesta a tu consulta. Esperamos tus comentarios al respecto.

    Saludos,

    Miguel

    MSDN/TechNet Soporte Comunidades

    Por favor, recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema.
    Es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde.

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft. Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    jueves, 20 de febrero de 2014 22:01
    Moderador
  • Hola, tras unos días revisando documentación sigo con el mismo problema y sin posibilidad de resolverlo. La verdad es que el tema me supera un poco. ¿Alguna recomendación más?
    jueves, 27 de febrero de 2014 21:58
  • Hola Conrrad

    Mira revisa tu designer de la tabla esto lo puedes ver el SQL Management y ahi verificar las reglas del identity de tu llave.

    espero que te sirva por favor comentanos.

    saludos


    Si la respuesta te fue util recuerda marcarla <br/> Jonathan S. Romero Jimenez <br/> Arquitecto .Net <br/> MCPD Azure <br/> MCPD Web Applications <br/> MCPD Windows Phone <br/> MCTS <br/> MCP

    viernes, 28 de febrero de 2014 22:48