none
Problemas al subir un archivo compilado al IIS RRS feed

  • Pregunta

  • DISCULPE AL PROBAR MI PAGINA WEB ECHO EN MVC3 , SUBIENDOLO AL IIS AL EXAMINAR LOS SE MUESTRA MI PAGINA WEB PERO SIN STYLOS COMO PODRÍA SOLUCIONAR POR FAVOR !! :(

    sábado, 15 de marzo de 2014 21:55

Respuestas

Todas las respuestas

  • hola

    a tu sitio le estas aplicando seguridad? porque quizas haya partes que no carguen como ser .js y .css porque no se esta autneticado

    tambien podrias usar el developr tool del IE (al cual accedes con F12) y en la solapa Red (Network) podrias iniciar la captura y ver si carga los .css y a que url quiere acceder

    recuerda que deberias usar el ~/ para referenciar los archivos de estilo

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina

    domingo, 16 de marzo de 2014 12:34
  • Hola Amigo,

    Disculpa no le estoy aplicando seguridad me fije las referencias estan asi!

     <link rel="stylesheet" href="../service-icons/style.css" /> y cuando lo ejecuto normal!

    pero cuando lo publico y pruebo el compilado en el IIS me sale una pagina sin stylos ni .js

    pero si me fijo la carpeta del compilado si estan los .css y .js 

    Ayuda.??

    Probé lo que me digiste acerca de la referencia ~/  en remplazo de ../ y cuando ejecuto me sale un pagina sin estilos .css ni .js 

    Amigo tambien probé lo del F12 y si tenias razon no esta jalando los .css ni .js a que se debe eso y como lo soluciono por favor

    • Editado jhosef123 lunes, 17 de marzo de 2014 13:48
    lunes, 17 de marzo de 2014 13:13
  • intenta usando

    <link rel="stylesheet" href="@Url.Content("~/service-icons/style.css")" />

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina

    • Marcado como respuesta jhosef123 martes, 18 de marzo de 2014 13:02
    lunes, 17 de marzo de 2014 14:43
  • Gracias Amigo logré solucionarlo, tambien renombre las carpetas !! 
    • Editado jhosef123 martes, 18 de marzo de 2014 13:01
    martes, 18 de marzo de 2014 13:01