none
Framework 4.5 en Visual Studio 2010 RRS feed

  • Pregunta

  • Hola amigos.

    Como puedo desarrollar aplicaciones en Visual Studio 2010 con el Framework 4.5, ¿que tengo que instalar?.

    Tengo el Visual Studio 2010 Ultimate SP1, siempre e trabajado con el, y ahora necesito trabajar con el framework 4.5.

    Agradeceria me ayudaran.

    exitos.


    wag_cor

    domingo, 12 de marzo de 2017 4:01

Respuestas

  • Hola wagcorp Si quieres utilizar .NET Framework 4.5 debes tener Visual Studio 2012 o superior. Las versiones anteriores no tienen soporte para dicho framework. Debes actualizarte a Visual Studio 2012.

    Pero...

    Utilizando la condición de inicio podrías llegar al objetivo.

    En el instalador, tenés que hacer clic derecho e ir a las condiciones de lanzamiento.

    En "Buscar máquina destino", clic derecho y "Agregar nueva búsqueda de registro":

    Property: REGISTRYVALUE1
    RegKey: Software\Microsoft\NET Framework Setup\NDP\v4\Full
    Root: vsdrrHKLM
    Value: Release

    Agrega la nueva condición de inicio:

    Condition: REGISTRYVALUE1>="#378389"
    InstallUrl: https://www.microsoft.com/es-ES/download/details.aspx?id=30653
    Message: El instalador requiere que sea instalado el.NET Framework 4.5.

    Espero resulte útil.

    Saludos


    Christian Amado
    Software Engineer | MCPD: Windows Phone Developer | MCTS: Silverlight Developer
    Don't forget to mark the right answer and vote up if helps you.
    My Blog
    My code samples

    • Propuesto como respuesta Joyce_ACModerator martes, 14 de marzo de 2017 15:57
    • Marcado como respuesta wagcorp viernes, 17 de marzo de 2017 1:34
    lunes, 13 de marzo de 2017 19:05