none
Problemas con conector de mysql RRS feed

  • Pregunta

  • Hola, les escribo porque tengo una pregunta. Tengo instalado el controlador de mysql versión 5.2.3, y varios proyectos relacionados a él. El problema es que estoy desarrollando un proyecto el cual utiliza el Entity Framework por lo cual necesito instalar el controlador nuevo versión 6.0.3, el problema es que no puedo instalarlo con el controlador 5.2.3 instalado y no quiero desinstalar éste para no tener que actualizar todas las referencias de mis demás proyectos.

    Tienen alguna solución? Hay alguna forma de poder instalar 2 controladores diferentes?

    Gracias!
    jueves, 11 de junio de 2009 17:33

Todas las respuestas

  • Hola
    Hace como 1 mes quize probar la funcionalidad de Entity Framework con MySQL y quite el conector 5 e instale el 6, no pude hacer mas nada

    Si la respuesta es correcta, marcala como correcta.
    Tambien puedes votar como util si te fue de ayuda
    DCE 5 ESTRELLAS PLATINO
    jueves, 11 de junio de 2009 17:40
  • Eso es lo que quiero, tener los 2 instalados.. pero veo que no se puede.. y de no poderse.. hay alguna forma de poder actualizar las referencias de los proyectos con el conector viejo al nuevo de forma rápida?
    jueves, 11 de junio de 2009 17:41
  • Tienes que tener mucho ciudado, recuerda que la version 6 esta todavia en Beta, y el soporte a EF es inicial, una de las cosas que me paso fue que en este nuevo conector se usa el "?" como marcador para parametros en vez del "@" como en la version anterior, esto me trajo problemas a la hora de actualizar el codigo 
    Saludos 
    Si la respuesta es correcta, marcala como correcta.
    Tambien puedes votar como util si te fue de ayuda
    DCE 5 ESTRELLAS PLATINO
    jueves, 11 de junio de 2009 17:45
  • Ese es un punto importantísimo! Vos decís que no acepta mas el "@"? o sea, si hago un comando con un select where id=@id no va a funcionar? me voy a volver chango cambiando cada parámetro... espero que alguien sepa de alguna otra forma más sencilla.

    Gracias por responder!
    jueves, 11 de junio de 2009 17:49
  • No se si por configuracion se pueda cambiar a la modalidad anterior, no tuve tiempo de revisar
    Si la respuesta es correcta, marcala como correcta.
    Tambien puedes votar como util si te fue de ayuda
    DCE 5 ESTRELLAS PLATINO
    jueves, 11 de junio de 2009 17:53
  • En una oportunidad hize un post donde prepare un video de Mysql con el conector 6 pero usando DataSets
    SALUDOS


    Si la respuesta es correcta, marcala como correcta.
    Tambien puedes votar como util si te fue de ayuda
    DCE 5 ESTRELLAS PLATINO
    jueves, 11 de junio de 2009 17:56
  • En una oportunidad hize un post  donde prepare un video de Mysql con el conector 6 pero usando DataSets
    SALUDOS


    Si la respuesta es correcta, marcala como correcta.
    Tambien puedes votar como util si te fue de ayuda
    DCE 5 ESTRELLAS PLATINO

    Gracias, lo voy a revisar.
    jueves, 11 de junio de 2009 17:56
  • Una pregunta.. acaso no se puede utilizar el conector 6 sin tener que instalarlo, referenciando a la dll?
    jueves, 11 de junio de 2009 19:29
  • hola

    otra opción dependiendo de tu espacio en disco duro y de tu memoria RAM, es que utilices una maquina virtual, y dentro de ella instales visual y el conector 6, asi podras hacer cualquier tipo de prueba o desarrollo y el host seguira trabajando con el connector 5.x, yo se que es bastante tardado, pero es muy recomendable el utilizar maquinas virtuales para que puedas estar probando tu software en distintos so, etc.

    Saludos
    Edgar López R.
    si la respuesta te fue de utilidad, no olvides marcarla como correcta o útil.
    viernes, 12 de junio de 2009 16:18