none
Error al cargar reporte con Crystal Report y dataset con consulta o vista RRS feed

  • Pregunta

  • Buen dia, nueva consulta ya que las dos anteriores nadie pudo resolverla.

    la pregunta es como puedo habrir reporte condataset y agregado un viewUsuarios este codigo cuando es una tabla funciona aqui utilizo dos tablas donde cree la vista si es una tabla no hay de necesidad de crearla asi tengo varios reportes con vistas si hay solucion para este lo realizo con los demas este solo tiene dos tablas. 

    el codigo es el siguiente:

    string locPath = Application.StartupPath;

                    SqlConnection connection2 = new SqlConnection("Data Source=...;Initial Catalog=....;Persist Security Info=True;User ID=...;Password=....");
                    SqlCommand command2 = new SqlCommand("Select * From viewUsuarios", connection2);
                    SqlDataAdapter adapter2 = new SqlDataAdapter(command2);
                      DataSet datasetRPT = new DataSet();
                    adapter2.Fill(datasetRPT, "viewUsuarios");
                    ReportDocument CustomerReport = new ReportDocument();
                    CustomerReport.Load(locPath + @"\\Reportes\\rptUsuariosA.rpt");
                    CustomerReport.SetDatabaseLogon("....", "...", "...", "...");
                    CustomerReport.SetDataSource(datasetRPT.Tables["SISBILOCDataSet"]);   ---nombre del dataset 
                    frmVisorCR VisualizarReporte = new frmVisorCR();
                    VisualizarReporte.PrepararReporte(CustomerReport);

                    VisualizarReporte.ShowDialog();

    alguien que me pueda ayudar o ver donde tengo el error cuando el reporte es con una tabla no tengo problemas le agregue la vista viewUsuarios al dataset y lo tengo.

    Cesar Lagos


    Cesar

    viernes, 13 de marzo de 2015 19:20