none
Error SQL server 2008 (error 107 y 18456) RRS feed

  • Pregunta

  • Hola,

    Mi problema es el siguiente, instale SQL server 2008 SP1 sobre un windows 2003 server R2 SP2 y esta dentro de un dominio, y en el visor de sucesos me encuentro estos dos errores cada vez que arranco el servidor:


    Tipo de suceso:    Errores
    Origen del suceso:    MSSQLSERVER
    Categoría del suceso:    Inicio de sesión
    Id. suceso:    18456
    Fecha:        01/03/2010
    Hora:        12:53:14
    Usuario:        DOMINIO\Admin
    Equipo:    SRV-CRM
    Descripción:
    Error de inicio de sesión del usuario 'DOMINIO\admin'. Motivo: no se puede abrir la base de datos explícitamente especificada. [CLIENTE: 192.168.1.3]

    Tipo de suceso:    Error
    Origen del suceso:    Report Server Windows Service (MSSQLSERVER)
    Categoría del suceso:    Administración
    Id. suceso:    107
    Fecha:        01/03/2010
    Hora:        12:53:14
    Usuario:        No disponible
    Equipo:    SRV-CRM
    Descripción:
    Report Server Windows Service (MSSQLSERVER) no se puede conectar con la base de datos del servidor de informes.

    Lo curioso que cuando quiero acceder a http://srv-crm/ReportServer y http://srv-crm/Reports puedo acceder sin ningún problema. También me descargue la maquina virtual de CRM y también tiene los mismos errores que comento.

    gracias.
    • Cambiado Fran DiazModerator miércoles, 20 de julio de 2011 10:28 Es de SSRS (De:SQL Server)
    lunes, 1 de marzo de 2010 12:23

Respuestas

  • Hola.

    Ya, pero es más una cuestión de orden que otra cosa (si no hay base de datos, no puedes hacer funcionar el reporting). De todos modos, es una situación que con un reinicio del servicio de reporting se solucionaría. ¿Estás encontrando algún problema a la hora de utilizar Reporting Services?


    Alberto López Grande (Visita mi blog en http://qwalgrande.blogspot.es/)
    martes, 2 de marzo de 2010 9:18
    Moderador

Todas las respuestas

  • Hola.

    A lo mejor es que aún no has realizado la configuración de Reporting Services. Mira en http://msdn.microsoft.com/es-es/library/bb839480(SQL.90).aspx, concretamente el apartado "Configurar Reporting Services".

    Si no fuera eso o no lo consigues, nos dices.

    Alberto López Grande (Visita mi blog en http://qwalgrande.blogspot.es/)
    lunes, 1 de marzo de 2010 13:01
    Moderador
  • Hola qwalgrande,

    La cuestión es que lo tengo configurado pero da ese mismo error. Si no lo tuviera bien configurado supongo que me daria algun error cuando accedo a las siguientes webs: (http://srv-crm/ReportServer y http://srv-crm/Reports) no?

    Gracias.


    lunes, 1 de marzo de 2010 15:42
  • Hola.

    Asegúrate de que la configuración está correctamente realizada. Obtienes dos errores, uno es de login, y te lo da el servidor de bases de datos. Otro es de Reporting, indicándote que no llegas a las bases de datos de reporting. Es posible que el usuario que arranca el servicio de Reporting carezca de permisos en el servidor de SQL Server o algún otro problema parecido. Completa otra vez el asistente de configuración de Reporting para cerciorarte.


    Alberto López Grande (Visita mi blog en http://qwalgrande.blogspot.es/)
    lunes, 1 de marzo de 2010 16:09
    Moderador
  • Hola,

    Voy a mostrarte unos pantallazos para que puedas valorar mejor:

    * error:

    http://img682.imageshack.us/img682/8958/58745347.jpg
    http://img710.imageshack.us/img710/2024/12952914.jpg
    http://img202.imageshack.us/img202/9595/59925543.jpg

    * después del error aparecen estos mensajes pero no como errores:

    http://img46.imageshack.us/img46/4595/63445976.jpg
    http://img237.imageshack.us/img237/6430/60411648.jpg
    http://img522.imageshack.us/img522/7374/38231462.jpg

    * Administrador de configuración de Reporting services:

    http://img15.imageshack.us/img15/4708/88428541.jpg
    http://img522.imageshack.us/img522/2034/11467618.jpg
    http://img297.imageshack.us/img297/4600/56909843.jpg
    http://img3.imageshack.us/img3/7100/69672345.jpg
    http://img13.imageshack.us/img13/4195/86999035.jpg
    http://img3.imageshack.us/img3/499/27187170.jpg
    http://img214.imageshack.us/img214/1662/48326003.jpg
    http://img517.imageshack.us/img517/2563/96085925.jpg
    http://img203.imageshack.us/img203/8362/36287931.jpg

    Saludos,
    Joan.
    lunes, 1 de marzo de 2010 18:59
  • Hola.

    ¿Esos mensajes salen después del error? Debes arrancar el servicio de SQL Server para que funcione el servicio de Reporting. Asegúrate de que está arrancado y luego arranca el servicio de Reporting.



    Alberto López Grande (Visita mi blog en http://qwalgrande.blogspot.es/)
    lunes, 1 de marzo de 2010 20:56
    Moderador
  • Buenos días,

    Pues si la verdad es que aparecen después del error, lo mas extraño es que los servicios están iniciados. Te adjunto una imagen justo en el momento después de reiniciar la maquina tal como están los servicios.

    http://img69.imageshack.us/img69/1284/65937202.jpg

    Joan.
    martes, 2 de marzo de 2010 7:55
  • Hola.

    Ya, pero es más una cuestión de orden que otra cosa (si no hay base de datos, no puedes hacer funcionar el reporting). De todos modos, es una situación que con un reinicio del servicio de reporting se solucionaría. ¿Estás encontrando algún problema a la hora de utilizar Reporting Services?


    Alberto López Grande (Visita mi blog en http://qwalgrande.blogspot.es/)
    martes, 2 de marzo de 2010 9:18
    Moderador
  • ok!

    En principio no tengo ningún problema con el reporting services, como la finalidad es instalar microsoft CRM ya lo podré comprobar!!

    Muchas gracias.
    martes, 2 de marzo de 2010 10:33