none
IIS RRS feed

  • Pregunta

  • Buenos dias

    Estoy tabajando con asp. net en visual studio 2010, y realizamos una aplicacion, cuando la levantamos en el servidor, si varios usuarios ingresan a la aplicacion truena, pero si uno solo entra no.

    No se si me pudieran ayudar a encontrar el problema.

    martes, 28 de mayo de 2013 22:21

Todas las respuestas

  • hola

    y truena con que mensaje de error ?

    en el codigo de casualidad usas alguna variable static (en c#) o Shared (en vb.net), porque declarar con esto puede traer problemas en un entorno web, deberias evitarlo y usar el objeto Session

    Nota: no olvides mencionar en que lenguaje programas


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina

    miércoles, 29 de mayo de 2013 2:11
  • Hola, revisa tambien que tu base de datos no esté configurada para acceso de single user!!


    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    miércoles, 29 de mayo de 2013 10:06
  • Buenos dias

    Estamos trabajando con c#

    Nada mas en las paginas utilizamos variables estaticas y para la conexion utilizamos objeros session.

    Saludos.

    miércoles, 29 de mayo de 2013 14:38
  • Hola buenos dias

    La base de datos esya configurada como "MULTI_USER"

    Saludos

    miércoles, 29 de mayo de 2013 14:49
  • es que no deberias usar en ningun lado variables estaticas, en niguna pagina

    porque sabes que significa usar variables static en un entorno web ? sabes que estas se comportan como el objeto application siendo estas compartidas por todos los usuarios del sitio

    quita esas variables estaticas del codigo

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina

    miércoles, 29 de mayo de 2013 15:28
  • gracias lo tomare encuenta, lo que me asa en si seria esto:

    • en mi aplizacion si yo entro como usuario
    • inicio la conexion
    • despues entro a un proceso
    • entra un usuario mas
    • inicia la conexion y entra a otro proceso
    • el el primer usuario que entro realiza otro proceso, se desconecta y manda mensaje de error

    miércoles, 29 de mayo de 2013 16:16