none
Funcion o Macro para contar palabra repetida en Excel RRS feed

  • Pregunta

  • Buenas tardes a todos!

     

    Tengo un problema....

    tengo un documento excel con muchisimos datos y necesito contar los valores/palabras repetidas en un campo llamado Servicio.

    el campo -Servicio- (A1) contiene:

     

    =SERVICIO=

    Telefonico

    Radiocomunicacion

    Comunicacion de datos

    Soporte tecnico

    etc, etc"

     

    encontre en internet un ejemplo:  =CONTAR.SI(A2:A5;"manzanas")  pues como veran cuenta la palabra "manzanas" de A2 hasta A5

    para mi caso seria =CONTAR.SI(A2:A5;"telefonico")  y las demas... ( no se si se puedan contar todas las palabras del campo en la misma funcion )

    al principio me marcaba errores y me di cuenta de que se debia a que la sintaxis era para Excel en español y yo lo tengo en ingles para lo que encontre la sintaxis en ingles..... =COUNTIF(A2:A5,"telefonico")

    ok hasta ahi todo iba de maravilla hasta que me di cuenta que me estaba contando valores que ya habia descartado!!. Me explico.... tengo otro campo llamado "Asigando a" (I1), en este campo estan contenidas varias zonas y no las necesito todas, para lo que anteriormente ya habia hecho el filtro de las zonas que necesito las cuales son:

    = ASIGNADO A =

    CD_TOPOLOBAMPO

    ME_TOPOLOBAMPO

    SR_TOPOLOBAMPO

    SR_GUAYMAS

    SR_ROSARITO

    ST_TOPOLOBAMPO

    ST_ROSARITO

    ST_GUAYMAS

     

    entonces lo que yo necesito es hacer el conteo de cada uno de los valores repetidos del campo "Servicios" (A1) pero que solo cuente en base al filtro que hise en "Asignado a" (I1), es decir... cuantos servicios TELEFONICO tengo en total en en las 8 zonas señaladas o filtradas???

     

    espero me puedan ayudar...... =(

     

    jueves, 3 de junio de 2010 18:40

Todas las respuestas