none
Problema con .exe no funciona en las maquinas clientes RRS feed

  • Pregunta

  • Hola,

    Estoy creando un instalador con Install Shield 2012, cuando lo instalo y ejecuto en mi maquina funciona perfecto, pero cuando lo instalo en otra estación de trabajo y ejecuto el .exe sencillamente no levanta, ni me da error alguno...lo único que incluí recientemente en el instalador fue un modulo que trabaja con crystal report. Si me pudieran dar alguna mano con esto...le agradeciere.

    martes, 21 de abril de 2015 14:25

Todas las respuestas

  • Hola, que tipo de proyecto estas realizando? asegurate en la solucion de que los ensamblados junto con las referencias , siempre se copien local al igual que las librerias (eso se hace a traves de las propiedades, porque si en tu maquina funciona y en las demas no,  puede ser debido a que algunas librerias o ensamblados no se hayan incluido en tu deploy.
    martes, 21 de abril de 2015 15:46
  • Estoy desarrollando un proyecto en WINFORM con VS2012 y .NET 4.5, antes de incluir el modulo de crystal report el ejecutable generado por el InstallShield corría bien en todas las estaciones, he estado viendo las dependencias de mis ensamblados y no veo nada incorrecto. Comprobé el .Net 4.5 en cada estación. Lo que me queda por probar es instalar el runtime de crystal report.
    martes, 21 de abril de 2015 15:56
  • Dale revisalo y nos cuentas, si lo que falla en los clientes es el modulo de crystal report es probable que sea debido a eso.
    martes, 21 de abril de 2015 16:03
  • Nada instale el runtime de crystal report y tampoco funciona.
    jueves, 23 de abril de 2015 16:12
  • para que me quede claro... Instalas tu aplicativo en otra maquina y cuando la ejecutas no sale nada? Has probado en ver los logs del EventViewer(Visor de eventos) de Windows? Tal vez te de información de lo que ocurre. También te recomiendo que en tu desarrollo implementes un sistema de log para tracear las excepciones que se produzcan.

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó, vótala como útil. Saludos


    jueves, 23 de abril de 2015 16:31
  • En vez de utilizar Install Shield, utiliza la opcion de publicacion que trae visual llamada Click One, y en tu servidor creas una carpeta , para que todos tus usuarios se conecten .

    http://www.textcontrol.com/en_US/blog/archive/20060221/

    slds

    PD:Revisa que todos los DLL necesario esten el Instalador ya que sin los DLL necesarios de hecho la aplicación te va a reventar.


    ProgramacionYa.net
    Si pequeña es la Patria, uno grande la sueña
    Rubén Darío
    Principe de las letras Castellanas
    Poeta Nicaragüense

    sábado, 25 de abril de 2015 8:15