none
Autenticarse continuamente con Firefox y Chrome cuando se despliega y se ejecuta App RRS feed

  • Pregunta

  • Hola!

    estoy desplegando una app y cuando quiero acceder a ella por primera vez con Chrome o Firefox siempre tengo que introducir las credenciales (ya que se despliega cada vez en una url diferente). 

    En Internet Explorer esto está resuelto indicando http://*.my-apps.com como sitio de confianza o en Intranet Local. 

    Supuestamente Chrome toma la configuración de Internet Explorer, pero en este caso no está funcionando y no sé por qué. El caso de Firefox la configuración es diferente, pero incluso siguiendo estas indicaciones no consigo que funcione como quisiera:

    http://superuser.com/questions/594049/how-to-enable-ntlm-for-all-intranet-sites-in-firefox

    Alguna idea?

    Gracias!

    PD: Si las developer tools de Explorer no fueran tan malas...

    viernes, 2 de enero de 2015 16:26

Todas las respuestas

  • Hola, para Chrome usa --auth-server-whitelist

    Ej:

    chrome.exe --auth-server-whitelist="*my-apps.com"

    En el caso de Firefox, agrega ".my-apps.com" en network.automatic-ntlm-auth.trusted-uris, es importante el punto (.)

    Otro punto para que revises, es si tienes habilitado "Loopback Check". También deshabilítalo.http://support2.microsoft.com/kb/926642/en-us

    Saludos.

    viernes, 2 de enero de 2015 17:21
  • Hola Christian,

    gracias por la respuesta, pero ninguno de los dos métodos me funciona.

    El asunto es que que si me autentico la primera vez, el resto va bien. El problema es que si estoy desplegando continuamente, me solicita las credenciales para el nuevo dominio que se ha creado, y eso me sigue pasando con las configuraciones que me comentas. 

    PD: estoy accediendo desde una máquina cliente, el tema del "Loopback check" además ya está superado.  :)


    • Editado SharePein viernes, 2 de enero de 2015 18:00
    viernes, 2 de enero de 2015 17:59