none
Problemas en conexión de sistema con SQL 2008 R2 RRS feed

  • Pregunta

  • buenos dias:

    tengo el siguiente problema, al querer conectar un sistema SQL me sale el error de: Valor de tiempo de espera caducado. el periodo de tiempo de espera ha caducado antes de completar la operacion o el servidor no responde. revise las posibles causas del problema con este articulo

    http://msdn.microsoft.com/es-es/library/ms190181.aspx

    hice las revisiones a la cadena de conexion del sistema: coloque la ip del servidor para colocar probe la conectividad, los firewalls estan configurados en los respectivos puertos, todo ok, tambien amplie el tiempo de conexion de 20 a 45 seg. y nada sigue saliendo el mismo problema.

    ahora nose si sera la version de SQL antes en pruebas pasadas ocupábamos SQL 2008 sp1 luego se compro la licencia y se instalo SQL 2008 r2 segun las personas q prueban el sistema q con los anteriores instaladores que ocupaban la otra version de SQL no le daba ese problema se conectaba.

    su conexion de ellos es satelital.

    Faltara alguna configuracion extra ???

    saludos

    carlos

     

    martes, 26 de octubre de 2010 15:59

Respuestas

  • Si este error esta ocurriendo al momento de realizar una transacción, verifica la propiedad CommandTimeout intenta poniendo esto:

    Command.CommandTimeout = 0;

     

    En todo caso puedes asignar el tiempo TimeOut que sea mas de lo que esta establecido para esta variable por defecto.


    Saludos, Willy Taveras
    martes, 26 de octubre de 2010 16:06
    Moderador

Todas las respuestas

  • Comprueba lo que indican estos artículos: http://ascii164.blogspot.com/search/label/CONEXION

    martes, 26 de octubre de 2010 16:04
  • Si este error esta ocurriendo al momento de realizar una transacción, verifica la propiedad CommandTimeout intenta poniendo esto:

    Command.CommandTimeout = 0;

     

    En todo caso puedes asignar el tiempo TimeOut que sea mas de lo que esta establecido para esta variable por defecto.


    Saludos, Willy Taveras
    martes, 26 de octubre de 2010 16:06
    Moderador
  • Leyendo el link q me pasaron revise el Sql Server Configuration Manager en la parte de Protocols for MSSQLSERVER el protocol name Named Pipes estaba en Disabled lo coloque en Enabled y reinicie el servicio

    probare si se puede conectar

    tambien estoy probando colocando commandtimeout en 60 q serian segundos

    veres q pasa

    saludos

    martes, 26 de octubre de 2010 18:20
  • hola:

    les comento que al parecer lo que daba problemas para la conexion era el parametro donde configuraba el servidor mirror, quitamos ese atributo generamos el instalador y colocamos el tiempo en 60 sg.  y se conecto al servidor. bueno aun no se si sera esa configuracion del servidor mirror tengo q buscar otras opciones sino de nada servira configurar el mirror en la oficina y q no se conecten los clientes.

    saludos.

     

    martes, 26 de octubre de 2010 20:46