none
Migración TFS 2008 a TFS 2012 RRS feed

  • Pregunta

  • Saludos,

    Andamos en pleno proceso de migración de TS2008 SP1 a TFS2012 Upgrade 4.

    Básicamente seguimos la guía http://msdn.microsoft.com/es-es/library/jj620933%28v=vs.110%29.aspx y la migración es en un nuevo servidor.

    Nuestro actual sistema dispone de:

    • Team Foundation Server 2008 SP1
    • Windows SharePoint Services 3.0 SP1
    • Scrum for Team System v2.1
    • SQL Server 2005 Standard x86 SP2

    Y queremos pasar a una nueva máquina con:

    • Windows Server 2012.
    • SQL Server 2012 Enterprise.
    • SharePoint Foundation 2010.
    • TFS 2012 Upgrade 4.

    Trabajamos en nuestros proyectos con la plantilla 2.1 para Scrum. Tras seguir todos los pasos y haber configurado Share Point Foundation 2010, Reporting Services, migrar los datos de TFS y actualizar TFS, empiezan los problemas:

    • No todos los informes se ven (unos cuantos dan distintos errores) ni veo la forma de que se actualicen automáticamente.
    • Crear un nuevo proyecto de equipo con portal Share Point asociado, siempre casca por "TF3017: Error en el complemento Microsoft.ProjectCreationWizard.Portal durante la tarea SharePointPortal del grupo Portal"

    Sin entrar en más detalle, por ahora :) , quería ver si alguno os topasteis con una situación similar y si disponéis de alguna posible solución (u otra distinta guía de actualización).

    Gracias de antemano.

    martes, 9 de septiembre de 2014 12:12

Todas las respuestas

  • Hola Guillermo,

    Lamento que no hayas recibido respuesta antes de algún otro miembro o moderador. 

    Revisando tu error a grosso modo y de acuerdo al proceso que mencionas en la creación del proyecto recuerdo una situación similar. 

    El problema que yo tenia al momento de crear el Team Proyect con un template era precisamente el mismo template, mencionas que estas usando el Scrum 2.1. Has hecho la prueba con otro template diferente? Si es así te dió el mismo error? 

    En mi caso la solución del problema estaba en el XML de configruación del template, lo que hice fue importarlo nuevamente y revisar que las líneas adicionales que agregue a mi template estuviera con la sintáxis correcta. Es un poco dificil revisarlo desde el panel de configuración del template en Visual Studio, mi recomendación es copiarlo a un archivo nuevo y abrirlo así para tener color al menos en el mismo.

    Saludos!

    Luis


    If the post was helpful to the solution of your problem or question please dont forget to flag it as 'Useful'

    miércoles, 12 de noviembre de 2014 18:07