none
Consulta no pertenece al miembro de 'TableAdapters' RRS feed

  • Pregunta

  • Hola, estoy usando una base de datos remota para poder comunicarse con el programa, pero cuando creo una nueva consulta en el adaptador de la tabla me dice que no pertenece al miembro del adaptador.

    Las demás consultas sí funcionan correctamente, incluso las que pertenecen a otras tablas. He seguido el mismo proceso para crearlas todas, incluso he comprobado que la sintaxis SQL es correcta y funciona.

    Gracias.

    jueves, 11 de diciembre de 2014 22:51

Respuestas

  • Hola alvrSG,

    Gracias por consultar en los foros. Mencionas que las demás consultas lo haces de la misma manera, pero a juzgar por la imagen que adjuntas, parecería que está mal declarada la de ActMedicamento, ¿Podrías mostrarnos como declaras algún otro Select que te funcione correctamente? Y además de lo que nos muestras, ¿No te da algún error de sintaxis?

    Saludos,

    Miguel

    MSDN/TechNet Soporte Comunidades

    Por favor, recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema.
    Es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde.

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft. Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.


    viernes, 19 de diciembre de 2014 17:31
    Moderador

Todas las respuestas

  • Hola:

     Podrías por favor detallar mas tu caso, si mencionas el error seria bueno que mencionaras bajo que condiciones se presenta al igual el fragmento de código señalando la linea donde se esta produciendo, de lo contrario dudo mucho que alguien pueda aportar mas que dudas y preguntas.


    Saludos desde Monterrey, Nuevo León, México!!!

    jueves, 11 de diciembre de 2014 23:43
  • hola

    el tema es cuando creas la consulta o cuando quieres invocarla ?

    estas seguro que no intentas acceder a un metodo de un tableadapter pero asignandolo a un datatable diferente

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    viernes, 12 de diciembre de 2014 0:53
  • El problema es la invocarla.

    Aquí se ve como está creada en el mismo DataTable:

    http://i.imgur.com/fACzscv.png

    Y aquí como llamo a la consulta.

    http://i.imgur.com/KjaHV7P.png

    viernes, 12 de diciembre de 2014 17:22
  • Hola alvrSG,

    Gracias por consultar en los foros. Mencionas que las demás consultas lo haces de la misma manera, pero a juzgar por la imagen que adjuntas, parecería que está mal declarada la de ActMedicamento, ¿Podrías mostrarnos como declaras algún otro Select que te funcione correctamente? Y además de lo que nos muestras, ¿No te da algún error de sintaxis?

    Saludos,

    Miguel

    MSDN/TechNet Soporte Comunidades

    Por favor, recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema.
    Es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde.

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft. Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.


    viernes, 19 de diciembre de 2014 17:31
    Moderador