none
Problema con reporte crystal XI RRS feed

  • Pregunta

  • buenas noches a todos, estoy haciendo un reporte en crystal que se alimenta de dos tablas y dos textbox desde un formulario aparte de donde va el crview, paso los datos de los textbox al formulario sin problemas pero me sale vacio solo salen los text.box, lo que quiero hacer es que me filtre la bd1 apartir del textbox1 que en un dni y me muestre los datos correspondientes, alguien me puede ayudar por favor?

    perdon, el enlace del reporte con las tablas los hago desde el asistente de cristal.
     
    este es el codigo con el que paso los datos de un formulario al report

    [code]Imports CrystalDecisions.Shared
    Public Class G_ficha_general


        Dim variable1 = G_examenes.GRADO_NUEVO
        Dim variable2 = G_examenes.DNI_REPORT
        Dim Rep As New CrystalReport3
        Dim Params As New ParameterValues
        Dim Par As New ParameterDiscreteValue

        Private Sub G_ficha_general_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

            Params.Clear()
            Par.Value = variable1
            Params.Add(Par)
            Rep.DataDefinition.ParameterFields("nuevo_grado").ApplyCurrentValues(Params)

            Params.Clear()
            Par.Value = variable2
            Params.Add(Par)
            Rep.DataDefinition.ParameterFields("report_dni").ApplyCurrentValues(Params)

            CrystalReportViewer1.ReportSource = Rep

           
        End Sub
    End Class[/code]


    Gracias a todos de antemano
    • Cambiado Enrique M. Montejo martes, 5 de abril de 2016 6:05 Pregunta relacionada con Crystal Reports.
    sábado, 2 de abril de 2016 20:42

Todas las respuestas

  • Hola José Antonio:

    El archivo que siempre tienes que cargar no es un rep, tiene que ser "rpt", que es el crea Crystal Reports. Mira a ver si por ahí viene la confusión, si no, lo indicas y continuaremos mirando donde está el problema.

    Un saludo.

    Gemma


    domingo, 3 de abril de 2016 11:37