none
Cambiar valor en My.Setting

    Pregunta

  • Hola a todos:

    Tengo un pequeño problema al querer guardar un valor booleano en My.Setting.

    Tengo otro valores guardados sin problemas, pero este no me deja. Está dado de alta en el Setings.Seting y también tiene su archivo designer en el cual se encuentra recogida la variable-

    Utilizo este pequeño código para poder cambiar el valor booleano a tru, pero no me deja, dándome el error de ña propiedad "AccessDec" es ReadOnly.

    'Comprobamos si la versión de Access esta convertida a decimal
            If Configuracion.strNombreBaseDeDatos = "MiCadenaConexion" Then
                If My.Settings.AccessDec = False Then
                    AccesoActualizacionDatos.CambiarTipoDatosAccessTablas()
                    My.Settings.AccessDec = True
                    My.Settings.Save()
                End If
            End If

    En la parte en negrita es donde no me deja cambiar el valor, dándome el error citado.

    No atino a saber por qué no me deja.

    Bueno, gracias todos.

    Un saludo.

    Gemma

    lunes, 17 de octubre de 2016 15:23

Respuestas

  • Hola Gemma, si tienes definida la propiedad como de ámbito de aplicación te dará ese mensaje porque son de solo lectura. Cambia el ámbito a usuario para que te deje modificarla.

    Saludos, Javier J

    • Marcado como respuesta gemma_campillo lunes, 17 de octubre de 2016 15:44
    lunes, 17 de octubre de 2016 15:36

Todas las respuestas

  • Hola Gemma, si tienes definida la propiedad como de ámbito de aplicación te dará ese mensaje porque son de solo lectura. Cambia el ámbito a usuario para que te deje modificarla.

    Saludos, Javier J

    • Marcado como respuesta gemma_campillo lunes, 17 de octubre de 2016 15:44
    lunes, 17 de octubre de 2016 15:36
  • Hola querido Javier:

    Pues si, esa era la solución. Ya recordaba yo que hace tiempo me pasó algo parecido pero no he atinado con lo que era.

    Bueno, querido amigo muchas gracias por tu ayuda. Ya está arreglado.

    Un abrazo.

    Gemma

    lunes, 17 de octubre de 2016 15:44