none
IIS7 no muestra imagenes svg RRS feed

  • Pregunta

  • Buenas, tal como lo dice el titulo  II6 no está mostrando las imagenes svg que tengo, las png y las jpg si las muestra, pero el problema está en qué no encuentra la ruta .Sin embargo la ruta está perfecta, antes estaba en un II8 y funcionaba a la perfección las imagenes svg, que debo hacer ?, no encuentro temas relacionados en ningún foro o ninguno se acerca  

    404: archivo o directorio no encontrado.

    Puede que se haya quitado el recurso que está buscando, que se le haya cambiado el nombre o que no esté disponible temporalmente.


    lunes, 16 de marzo de 2015 19:58

Respuestas

Todas las respuestas

  • Dos opciones:

    - En la consola de administración del IIS, accede a la configuración del sitio web. Tendrás una opción para indicar los tipos MIME admitidos. Añade la extensión .svg como tipo image/svg+xml.

    - En el web.config de tu sitio web añade en la sección <system.webServer>:

    <staticContent>
        <mimeMap fileExtension=".svg" mimeType="image/svg+xml" />
    </staticContent>

    lunes, 16 de marzo de 2015 20:04
  • Ya no me sale error pero la imagen sigue svg sigue sin mostrar, ademas en la consola javascript sale la siguiente linea

    Resource interpreted as Image but transferred with MIME type image/svg+xml.: "http://190.144.87.107/Default/css/images/top-3200.svg".

    PD: Si abro algun navegador en el servidor local la pagina me carga perfectamente, sin embargo no publicamente

    lunes, 16 de marzo de 2015 21:17
  • Es posible que sea un problema de caché. Elimina los temporales de tu navegador o, mejor, créate una copia de la imagen con otro nombre e intenta acceder para ver si es esa la causa.
    lunes, 16 de marzo de 2015 21:36