none
ERROR AL INTENTAR TENER ACCESO AL REGISTRO DEL SISTEMA RRS feed

  • Pregunta

  • La situación es la siguiente,

    Instalé Windows 7 32 bits e instalé Visual Studio 6.0 y todo funcionaba bien.

    Ahora,  cargo un proyecto Visual Basic y luego intento Ir a Proyecto y luego Referencias y me despliega una ventana diciendo: "ERROR AL INTENTAR TENER ACCESO AL REGISTRO DEL SISTEMA",

    He estado buscando la solución y encontre que debo ejecutar un programa llamado "Scr8_webregfix.exe". Pero este no me ha resuelto el problema. Qué puedo intentar? UAC esta desactivado.

    Gracias, espero ancioso una ayuda.


    Renee

    lunes, 18 de febrero de 2013 15:37

Respuestas

  • Lo he resuelto.

    He descargado subinacl.msi

    y luego he aplicado un .bat

    c:
    cd /d "%programfiles%\Windows Resource Kits\Tools"
    rem Cambio propietario
    subinacl /subkeyreg HKEY_CLASSES_ROOT /setowner=administradores
    pause
    rem Reasigno permisos de seguridad
    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administradores=f /grant=system=f /grant=usuarios=r
    pause
    rem Anulado porque no hizo falta
    rem subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administradores=f /grant=system=f /grant=usuarios=r
    rem subinacl /subkeyreg HKEY_CURRENT_USER /grant=administradores=f /grant=system=f /grant=usuarios=r

    Esto enviado por un usuario en este foro.


    Renee

    lunes, 18 de febrero de 2013 16:07

Todas las respuestas

  • Lo he resuelto.

    He descargado subinacl.msi

    y luego he aplicado un .bat

    c:
    cd /d "%programfiles%\Windows Resource Kits\Tools"
    rem Cambio propietario
    subinacl /subkeyreg HKEY_CLASSES_ROOT /setowner=administradores
    pause
    rem Reasigno permisos de seguridad
    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administradores=f /grant=system=f /grant=usuarios=r
    pause
    rem Anulado porque no hizo falta
    rem subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administradores=f /grant=system=f /grant=usuarios=r
    rem subinacl /subkeyreg HKEY_CURRENT_USER /grant=administradores=f /grant=system=f /grant=usuarios=r

    Esto enviado por un usuario en este foro.


    Renee

    lunes, 18 de febrero de 2013 16:07
  • Muchas gracias a mi me funciono perfectamente después de haber intentado otras muchas soluciones sin éxito.

    Saludos.

    jueves, 3 de agosto de 2017 15:45