none
¿Aplicaciones hechas en visual basic 2010 compatibles con windows XP? RRS feed

  • Pregunta

  • amigos he echo una aplicacion de escritorio en visual basic 2010 pero al querer instalar en windows xp me tira error. ya he instalado el net framework 3.5, que es lo que utilize para desarrollar y aun asi no funciona. A caso no es posible ejecutar esas aplicaicones en windows xp y que solo sean compatibles en windows 7.
    miércoles, 14 de septiembre de 2011 2:07

Respuestas

Todas las respuestas

  • claro que se puede ejecutar

    solo que puede que el error no sea de .net o casuado por win xp, sino que es un error no controlado el que genera el fallo

    no obtienes ningun mensaje cuando falla, solo no ejecuta  ?

     

    has validado que sea .net 3.5 el que usas, no? de casualidad no sera que suaste .net 4

     

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    miércoles, 14 de septiembre de 2011 2:19
  • bueno me tira el siguiente error

    unable to find a version of the runtime to run this application

    y si desde un principio seleccione en las opciones de compilacion

    Version de .NET framework de destino (todas las configuraciones)

     

    seleccione el 3.5. pero no entiendo que es lo que esta pasando.

    no se si eso es lo que me tratas de decir.

     

    o no sera que el windows xp no tenga los suficientes requisitos. peus ya que es un sp3 UE

     

     

     

    miércoles, 14 de septiembre de 2011 2:27
  • en esta opcion

     

    Properties Target Framework

    dice en tu caso .net 3.5

     

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    miércoles, 14 de septiembre de 2011 2:39
  • amigo no puedo configurar eso en mi aplicacion no aparece esa opcion, y estoy desarrollando en visual basic jeje no uso C# aun soy novato.


    miércoles, 14 de septiembre de 2011 3:06
  • Amigo muchas gracias, creo que ya se resolvio mi problema, instalaba en net 3.5  pero no era el completo, me descargue el pack completo y por fin ya funciono la aplicacion... muchas gracias de antemano amigo.
    miércoles, 14 de septiembre de 2011 3:33
  • no ahs revisado si esta opcion esta en alguna otra solapa de las propiedades

    en algun punto deberias poder ver para que version de .net esta compilando el proyecto,  ay que sino puede determinarlo puede que este compilando para .net 4

    es mas podrias hacer la prueba de instalar .net 4 en Win Xp y asegurarte si con este ejecuta, si lo ahce entonces es eso, estabas usando .net 4

     

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    miércoles, 14 de septiembre de 2011 3:38
  • el asunto creo que  esta en el boton  configuracion de windows en propiedades del proyecto VB2012 ultimate, hay un apartado  mas o menos así:

    <compatibility xmlns="urn:schemas-microsoft-com:compatibility.v1">

        <application>
          <!-- Lista de todas las versiones de Windows con las que esta aplicación está diseñada para funcionar. 
          Windows seleccionará automáticamente el entorno de mayor compatibilidad.-->
          <!-- Si la aplicación está diseñada para funcionar con Windows Vista, quite los comentarios del siguiente nodo supportedOS-->
          <!--<supportedOS Id="{e2011457-1546-43c5-a5fe-008deee3d3f0}"></supportedOS>-->
          <!-- Si la aplicación está diseñada para funcionar con Windows 7, quite los comentarios del siguiente nodo supportedOS-->
          <!--<supportedOS Id="{35138b9a-5d96-4fbd-8e2d-a2440225f93a}"/>-->
          <!-- Si la aplicación está diseñada para funcionar con Windows 8, quite los comentarios del siguiente nodo supportedOS-->
          <!--<supportedOS Id="{4a2f28e3-53b9-4441-ba9c-d69d4a4a6e38}"></supportedOS>-->
        </application>
      </compatibility>

    estoy buscando si hay alguna clave que se pueda añadir para que funcione en XP, si alguien sabe como comente, Saludos...

    sábado, 20 de octubre de 2012 2:55