none
Publicar Webservice asmx RRS feed

  • Pregunta

  • Hola,

    Tengo que hacer un webservice y estoy bastante perdido...

    Ejecutando VisualStudio funciona, ahora lo he publicado, añadido a IIS, examino la ip con el puerto que le puse y me lista los ficheros, añadí un tipo MIME con: Extensión  .asmx y application/x-www-form-urlencoded

    Cuando pulso en el fichero con extension .asmx me pregunta para guardar el fichero... que puede ser?

    • Cambiado Alberto PoblacionMVP martes, 14 de julio de 2020 21:06 Estaba en el foro de C# pero es una pregunta sobre publicación en ASP.NET
    martes, 14 de julio de 2020 16:18

Respuestas

Todas las respuestas

  • Hola J.Ramon, 

      

    Este sección del foro es para responder consultas sobre C#. igual te dejo este enlace que te puede ayudar.

    https://social.msdn.microsoft.com/Forums/en-US/15a7ea5c-5f27-481c-bbdf-a60a99908e51/publish-asmx-web-service?forum=asmxandxml

    Gracias por usar los foros de MSDN.   

     

     Andres Aguilar

     ____________________________ 

      

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde.  

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.   

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft. 

    martes, 14 de julio de 2020 19:53
    Moderador
  • hola

    >>examino la ip con el puerto que le puse y me lista los ficheros

    pero en la url pones

    http://localhost:puerto/service1.asmx

    donde service1 es el nombre del servicio

    porque debes ponerlo completo ya que parece ser no tienes un default en el sitio

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    martes, 14 de julio de 2020 21:06
  • Hola Leandro Tuttini

    Si, tengo puesto el default: Webservice1.asmx

    Saludos.

    miércoles, 15 de julio de 2020 7:49
  • Hola Andres Aguilar M

    He estado mirandolo pero eso es para colgarlo en un dominio, yo necesito tenerlo funcionando en un servidor, ya que es una función que realiza actualizaciones sobre una base de datos local en Foxpro.

    Saludos.

    miércoles, 15 de julio de 2020 7:57
  • Hola J.Ramon, 

      

    ah okay bueno dices que lo publicas con IIS aqui está un enlace que te puede ayudar a hacer el deploy del webservice en IIS viene bastante resumido. 

    Gracias por usar los foros de MSDN.   

     

     Andres Aguilar

     ____________________________ 

      


    • Marcado como respuesta J.Ramon jueves, 16 de julio de 2020 10:18
    miércoles, 15 de julio de 2020 20:17
    Moderador