none
[SQL SERVER 2005] Replicacion de Datos no se detiene RRS feed

  • Pregunta

  • Estimados,

    Tengo el siguiente ambiente:

    [SC] Publicador (Servidor Central)

    SELECT SERVERPROPERTY('productlevel')
    SP4

    SELECT @@VERSION

    Microsoft SQL Server 2005 - 9.00.5000.00 (X64)
        Dec 10 2010 10:38:40
        Copyright (c) 1988-2005 Microsoft Corporation
        Enterprise Edition (64-bit) on Windows NT 6.1 (Build 7601: Service Pack 1)

    [ST] Subcriotor (Servidor Central) --- Re - Publicador (Servidor Tienda)

    SELECT SERVERPROPERTY('productlevel')

    SP4

    SELECT @@VERSION


    Microsoft SQL Server 2005 - 9.00.5000.00 (Intel X86)
        Dec 10 2010 10:56:29
        Copyright (c) 1988-2005 Microsoft Corporation
        Standard Edition on Windows NT 6.1 (Build 7600: )

    [CX] Subcriptor (Caja 1)

    SELECT SERVERPROPERTY('productlevel')

    SP4

    SELECT @@VERSION
    Microsoft SQL Server 2005 - 9.00.5000.00 (Intel X86)
        Dec 10 2010 10:56:29
        Copyright (c) 1988-2005 Microsoft Corporation
        Express Edition with Advanced Services on Windows NT 5.1 (Build 2600: Service Pack 3)

    [CX2] Subcriptor (Caja 2)

    SELECT SERVERPROPERTY('productlevel')

    SP4

    SELECT @@VERSION
    Microsoft SQL Server 2005 - 9.00.5000.00 (Intel X86)
        Dec 10 2010 10:56:29
        Copyright (c) 1988-2005 Microsoft Corporation
        Express Edition with Advanced Services on Windows NT 5.1 (Build 2600: Service Pack 3)

    [CX3] Subcriptor (Caja 3)

    SELECT SERVERPROPERTY('productlevel')

    SP4

    SELECT @@VERSION
    Microsoft SQL Server 2005 - 9.00.5000.00 (Intel X86)
        Dec 10 2010 10:56:29
        Copyright (c) 1988-2005 Microsoft Corporation
        Express Edition with Advanced Services on Windows NT 5.1 (Build 2600: Service Pack 3)

    Paso a comentar mi problema:

    He generado las correspondientes Snaphost en el SC y ST, y claramente las correspondientes Subcripciones (CX1 y CX2), de la siguiente forma:

    • Generacion Snapshot en SC
    • Aplicar Subcripción en ST
    • Generación Snapshot en ST
    • Aplicar Subcripción en CX1 y CX2

    Hasta este momento ningún problema y ya han pasado más de 1 mes funcionando sin problemas aparentes.

    El dia "X", CX1 dejó de funcionar (problemas de Hardware), dado a esto se implementó un equipo de respaldo con las mismas caracterísitcas (CX3), generé nuevamente la subcripción al ST, y al momento de sincronizar procesó por más de 7 hrs. y seguía en funcionamiento, dado a esto me ví en la situación de solamente dejar CX2 funcionando.

    Tengo un ambiente de Desarrollo exactamente igual al expuesto, y he realizado las mismas pruebas (pruebas exitosas) demorándose alrededor de 1 hr a 2 hr en procesar (mismo Backup y mismos filtros en réplica).

     

    Alguien le ha pasado algo similar a esto y/o cómo puedo hacer para solucionarlo ??...

     

    Si necesitan más datos de SC - ST y CX´x, no hay problemas...

     

    Saludos Cordiales,

    miércoles, 4 de enero de 2012 18:50

Respuestas

  • Hola,

    Este error pueden ser varias cosas, podria ser que no tiene todos los componentes de SQL Client Instalados en la maquina CX3 verifica que esten todos Instalados y Ok, lo otro es posible que puedan existir problemas de resolucion de nombres y por ultimo los permisos con que estas creando las suscripción aunque si es el mismo de las demas no deberia de ser problema.

     

    Quedamos atentos.

     

    Javier Mauricio Castrillon

    Twitter: @jmcastrillon

     

    miércoles, 4 de enero de 2012 21:21

Todas las respuestas

  • Hola,

    En los log de los agentes no se presenta nada ?, de ser asi podrias habilitar el Logging  para tener mas detalle de lo que esta pasando :

    http://support.microsoft.com/kb/312292/en-us  (How to enable replication agents for logging to output files in SQL Server)

    Por otro lado podrias revisar el siguiente link donde dan los primeros pasos para hacer troubleshooting al ambiente de replicacion

    http://blogs.msdn.com/b/repltalk/archive/2010/02/04/first-steps-in-troubleshooting-replication.aspx

    Cuentanos que vas encontrando para ayudarte.

     

    Javier Mauricio Castrillon

    Twitter: @jmcastrillon

     

    miércoles, 4 de enero de 2012 19:00
  • Hola Javier,

    Gracias por la respuesta.

    Estube revisando con más calma los Logs, y el log replmerg.log (almacena información solo de las últimas 6 hrs aprox... esto está bien ??) no lo había chequeado, y me salto el siguiente error en la CX3:

    The subscription to publication 'PUBLICACION_PRODUCCION' could not be verified. Ensure that all Merge Agent command line parameters are specified correctly and that the subscription is correctly configured. If the Publisher no longer has information about this subscription, drop and recreate the subscription.

    Lo que me resulta raro, es que las otras publicaciones no tiene este tipo de error, por tanto se siguen sincronizando sin problemas.

    Y lo que me está sugeriendo es la Recreación de la Subscripción siendo que ya le he subcrito en más de una ocasión, volveré a intentar (parando todos los demás subcriptores para descartar sobrecarga del ST).

     

    Saludos cordiales,


    miércoles, 4 de enero de 2012 19:34
  • Hola,

    Este error pueden ser varias cosas, podria ser que no tiene todos los componentes de SQL Client Instalados en la maquina CX3 verifica que esten todos Instalados y Ok, lo otro es posible que puedan existir problemas de resolucion de nombres y por ultimo los permisos con que estas creando las suscripción aunque si es el mismo de las demas no deberia de ser problema.

     

    Quedamos atentos.

     

    Javier Mauricio Castrillon

    Twitter: @jmcastrillon

     

    miércoles, 4 de enero de 2012 21:21
  • Cuando añadiste CX3, volviste a generar el snapshot global de la publicación en ST? Dado que si el snapshot es antiguo no contendrá los datos del mes siguiente (o del tiempo que lleve la replica en funcionamiento), y esto puede hacer que una vez que CX3 se descargue el snapshot tenga que aplicar 1 a 1 todos las modificaciones que han ocurrido desde la fecha que se generó el snapshot global y por eso tarde tanto.
    Fran Lens http://es.linkedin.com/in/franlens

    Please remember click the Mark as Answer button if a post helps you to solve the problem
    jueves, 5 de enero de 2012 10:45
  • Hola.

    ¿Resolviste el problema?


    Alberto López Grande
    SQL Server MVP
    Visita mi blog en http://qwalgrande.blogspot.es/ Sígueme en twitter en http://twitter.com/qwalgrande

    sábado, 14 de enero de 2012 17:12
    Moderador