none
URGENTE!! Error de windows installer al querer instalar una aplicación compilada en VS 2005 RRS feed

  • Pregunta

  • Hola, tengo una consulta relacionada con los proyectos de instalación y Windows Installer:

    Hace un año terminé con el desarrollo de un sistema en Visual Studio 2002 (el cual consiste de un winservice) y lo empaqueté en un proyecto de instalación y todo funcionó correctamente. Ahora, un año después dispongo de Visual 2005 instalado en mi máquina y me han pedido que realice una modificación a dicho sistema; compilo la solución completa y lo empaqueto en VS 2005 sin ningún problema pero cuando quiero ejecutar el instalador de la aplicación, casi al finalizar me aparece un alerta como el siguiente: "InstallUtilLib.dll: Unknow error" y me aborta el proceso.

    Al principio crei que era un problema en la conversión del proyecto a la versión 2005, pero probé creando un proyecto nuevo y simple (solo un winform) pero me sigue apareciendo el mismo error casi al finalizar la instalación. También pensé que podía ser problema de que la instalación del VS 2005 estuviese corrupta, así que probé compilar y empaquetar la solución en otro equipo que también cuenta con VS 2005 pero me sigue apareciendo siempre el mismo problema.

    Desde ya agradezco la ayuda que puedan darme, la cual necesito con cierta urgencia porque me piden que estos cambios esten listos cuanto antes.

     

    Saludos , Diego

    lunes, 23 de abril de 2007 12:16

Todas las respuestas

  •  

    Hola,

     

    Que mal suena eso...

     

    Me suena a alguna incompatibilidad entre el 2002 y el 2005...

     

    Por cierto todavia hay gente que usaba el 2002 con el framework 1.0 ???.... madre mia

     

    Prueba a buscar esa dll en la instalacion anterior que tenias en el 2002...

     

    Copiala y agregala como referencia directamente al proyecto de instalacion

     

    A ver si asi te deja.

     

    Un saludo.

    lunes, 23 de abril de 2007 12:27
  • No creo que sea un problema de incompatibilidad de versiones porque, como mencioné antes, el mismo problema se me presenta cuando arranco con un proyecto de desde cero en 2005 y le hago un instalador (o sea, cuando lo quiero instalar tengo el mismo problema).

    Vale aclarar que yo ya formatié el equipo dos o tres veces desde que usaba el 2002, o sea que no existen posibilidades de que una instalación haya sobreescrito a la otra o hayan quedado componentes desactualizados.

     

    Ah, respecto a los que usan el Visual Studio 2002 y el Framework 1.0, yo ya me actualicé hace un año y ahora no quiero volver a usarlos nunca más, jeje ; pero te horrorizarías aún más al saber que todavía hay muchas empresas de acá de Córdoba que siguen usando ASP y Visual Basic 6.

    lunes, 23 de abril de 2007 13:03