none
Error 'Microsoft.ReportViewer.WinForms al ejecutar RRS feed

  • Pregunta

  • Hola buenas, me ha surgido un problema , resulta que cuando ejecuto mi aplicacion en otro pc me sale este error:

    No se puede cargar el archivo o ensamblado 'Microsoft.ReportViewer.WinForms

    he mirado por internet y he visto que hay que meter 3 librerias en la carpeta /bin, pero ni con esas.

    System.InvalidOperationException: Error al crear el formulario.

    Consulte Exception.InnerException para obtener más detalles.

    Error: No se puede cargar el archivo o ensamblado 'Microsoft.ReportViewer.WinForms, Version=11.0.0.0,

    Culture=neutral, PublicKeyToken=89845dcd8080cc91' ni una de sus dependencias. El sistema no puede encontrar

    el archivo especificado. ---> System.IO.FileNotFoundException: No se puede cargar el archivo o ensamblado

    'Microsoft.ReportViewer.WinForms, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91'

    ni una de sus dependencias. El sistema no puede encontrar el archivo especificado.


    Gracias

    • Cambiado Enrique M. Montejo martes, 15 de mayo de 2018 6:44 Pregunta relacionada con el control de informes de Windows Forms.
    jueves, 20 de febrero de 2014 22:23

Respuestas

  • Uso vs 2012, pero eso quiere decir que tengo que tenerlo instalado en cada pc que quiera ejecutar la apliacion?.

    He probado con 2008 y 2010 y nada supongo que hara falta la 12, la instalo y me dice que necesito Microsoft SQL Server "Denali" CTP3 System CLR Types, y me pone la url de descarga, pero no existe.

    Ya lo solucione: necesitas la version de RV 2012 y este archivo

    http://download.microsoft.com/download/F/E/D/FEDB200F-DE2A-46D8-B661-D019DFE9D470/ENU/x86/SQLSysClrTypes.msi

    Gracias


    • Editado Adm1990 domingo, 23 de febrero de 2014 13:32
    • Marcado como respuesta Adm1990 domingo, 23 de febrero de 2014 13:32
    domingo, 23 de febrero de 2014 13:23
  • hola, eso me parece viene asociado a la version de vs que usas, acá te paso un enlace

    http://www.microsoft.com/es-es/download/details.aspx?id=6576

    desconozco en ue versión viene la 11 quizas 2008 o 2010


    Si la respuesta te fue útil vótala como tal,y si fue respuesta márcala.
    Saludos.
    Lima-Perú


    • Editado Augusto1982 sábado, 22 de febrero de 2014 17:56
    • Marcado como respuesta Adm1990 domingo, 23 de febrero de 2014 13:32
    sábado, 22 de febrero de 2014 17:56

Todas las respuestas

  • Sigo sin poder solucionarlo.
    viernes, 21 de febrero de 2014 14:57
  • hola , has revisado si tienes esas librerías en la gac

    c:/windows/assemblies , si no es asi de berias instalar uno de los paquetes redistribuibles para que lo ponga ahi ,

    creo que este es el enlace debes elegir de acuerdo a la version en que desarrollaste tu aplicativo

    http://www.microsoft.com/es-es/download/details.aspx?id=6442 


    Si la respuesta te fue útil vótala como tal,y si fue respuesta márcala.
    Saludos.
    Lima-Perú

    sábado, 22 de febrero de 2014 1:17
  • gracias por responder, si que tengo la libreria, aun asi lo vuelvo a instalar y nada. sigue saliendo el error.
    sábado, 22 de febrero de 2014 14:28
  • fíjate si es la misma versión la del gac

    Version=11.0.0.0


    Si la respuesta te fue útil vótala como tal,y si fue respuesta márcala.
    Saludos.
    Lima-Perú

    sábado, 22 de febrero de 2014 14:33
  • cierto, tengo la 10, sabes donde puedo conseguir la 11?

    Estoy buscandola. gracias

    sábado, 22 de febrero de 2014 15:59
  • hola, eso me parece viene asociado a la version de vs que usas, acá te paso un enlace

    http://www.microsoft.com/es-es/download/details.aspx?id=6576

    desconozco en ue versión viene la 11 quizas 2008 o 2010


    Si la respuesta te fue útil vótala como tal,y si fue respuesta márcala.
    Saludos.
    Lima-Perú


    • Editado Augusto1982 sábado, 22 de febrero de 2014 17:56
    • Marcado como respuesta Adm1990 domingo, 23 de febrero de 2014 13:32
    sábado, 22 de febrero de 2014 17:56
  • Uso vs 2012, pero eso quiere decir que tengo que tenerlo instalado en cada pc que quiera ejecutar la apliacion?.

    He probado con 2008 y 2010 y nada supongo que hara falta la 12, la instalo y me dice que necesito Microsoft SQL Server "Denali" CTP3 System CLR Types, y me pone la url de descarga, pero no existe.

    Ya lo solucione: necesitas la version de RV 2012 y este archivo

    http://download.microsoft.com/download/F/E/D/FEDB200F-DE2A-46D8-B661-D019DFE9D470/ENU/x86/SQLSysClrTypes.msi

    Gracias


    • Editado Adm1990 domingo, 23 de febrero de 2014 13:32
    • Marcado como respuesta Adm1990 domingo, 23 de febrero de 2014 13:32
    domingo, 23 de febrero de 2014 13:23
  •  Hola. He estado buscando solucion con el mismo tema que has estado planteando y aun estoy sin resolverlo y sin encontrar nada util. Tu pudiste arreglar esto. Me ayduas por favor. Gracias
    viernes, 23 de enero de 2015 8:20
  • Yo estoy programando en C# y tu respuesta me fue de mucha ayuda gracias solo que el link del reportviewer 2012 es https://www.microsoft.com/es-mx/download/details.aspx?id=35747 solo que no se si sea buena practica instalarlos en el Server

    Gracias!!

    martes, 9 de junio de 2015 15:25
  • sabes yo le agregue unas modificaciones en la seccion de html...para que reconociera mi rv

    ceca con esto...yo tenia el mismo error pero con visual 2013 y le añadi esto en la seccion de app.config

     <startup useLegacyV2RuntimeActivationPolicy="true">
            <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.5" />
        </startup>
    </configuration>

    jueves, 25 de junio de 2015 4:28
  • Hola Eidy_Noh

    Al parecer el error que tu mencionas suele pasar pero con el Crystal Reports:

    https://social.msdn.microsoft.com/Forums/es-ES/80fb10bf-4582-4aa8-a89c-27968f598de7/vs-community-2013-y-cristall-reports-framwer-45-?forum=vsrepcrystales

    Saludos :)

    jueves, 25 de junio de 2015 6:44
  • Hola no se si aún siguen con el problema pero yo lo solucione.....

    en la PC donde instalan el programa deben también instalar estos 2 archivos... en el orden que los pongo....

    PRIMERO: https://www.microsoft.com/es-es/download/details.aspx?id=35580

    SEGUNDO: https://www.microsoft.com/es-es/download/details.aspx?id=35747

    YO LOS INSTALE Y VOLVI A INSTALAR EL PROGRAMA Y ME FUNCIONO... YA NO ME DIO ESE MALDITO ERROR...!!!!

    Espero les sirva... y si es así favor no te olvides de marcarla como respuesta...!!!!

    Saludos

    Luisin..!!!!

    • Propuesto como respuesta Joaquin Bresaan viernes, 11 de diciembre de 2015 14:51
    viernes, 14 de agosto de 2015 5:11
  • Exacto Gracias!!
    martes, 8 de diciembre de 2015 5:40
  • Hola no se si aún siguen con el problema pero yo lo solucione.....

    en la PC donde instalan el programa deben también instalar estos 2 archivos... en el orden que los pongo....

    PRIMERO: https://www.microsoft.com/es-es/download/details.aspx?id=35580

    SEGUNDO: https://www.microsoft.com/es-es/download/details.aspx?id=35747

    YO LOS INSTALE Y VOLVI A INSTALAR EL PROGRAMA Y ME FUNCIONO... YA NO ME DIO ESE MALDITO ERROR...!!!!

    Espero les sirva... y si es así favor no te olvides de marcarla como respuesta...!!!!

    Saludos

    Luisin..!!!!

    Tengo el mismo problema pero con visual studio community 2015, en C#; pero en el primer enlace aparecen muchas descargas, se refiere a descargar e instalar todas?

    De antemano gracias por la información

    martes, 24 de mayo de 2016 2:23
  • Hola, yo cambié la librería por otra anterior con una versión 10.0.0.0

    C:\Program Files (x86)\Microsoft Visual Studio 10.0\ReportViewer\Microsoft.ReportViewer.WinForms.dll

    Un saludo

    lunes, 14 de mayo de 2018 11:40