none
por que pasa esto? RRS feed

  • Pregunta

  • buenas tardes a todos

    tengo un formulario con varios groupbox y dentro de ellos hay datagridview's el problema es que puedo modificar la fuente a todos mis datagridview's excepto a uno

    no se que pueda ser incluso hice un boton de prueba para setearle una fuente especifica a ese datagridview pero no pasa nada

    ya me desespere!

    gracias

    • Editado RHCRD martes, 21 de julio de 2015 23:03
    martes, 21 de julio de 2015 23:02

Respuestas

  • Mira en ocasiones se corrompen los controles, a mi me ha pasado que eliminando el item y volviendo a agregarlo funca y no se ni porque se soluciona, posiblemente son bugs de asp. Asi que eso puede ser lo que paso

    Si mi respuesta fue útil ayudame marcándola como correcta.

    miércoles, 22 de julio de 2015 15:37

Todas las respuestas

  • Pon el codigo mi estimado 

    Si mi respuesta fue útil ayudame marcándola como correcta.

    martes, 21 de julio de 2015 23:34
  • puedo poner el codigo pero te aseguro que de nada sirve

    Private Sub BTN_Click(sender As System.Object, e As System.EventArgs) Handles BTN.Click
            DataGridView1.DefaultCellStyle.Font = New Font(Font.Name, Font.Size, FontStyle.Strikeout)
        End Sub

    les repito que ese codigo solo no funciona con un solo datagridview con todos los demas si funciona

    martes, 21 de julio de 2015 23:38
  • Y si pones todo el codigo? seguro encontramos la diferencia bro

    Si mi respuesta fue útil ayudame marcándola como correcta.

    martes, 21 de julio de 2015 23:47
  • todo el codigoo?

    pfff para aburrir
    no creo que sea en el codigo si lo que piensas es que en algun evento vuelvo a cambiar la fuente a "regular"

    mi codigo tiene 1400 lineas no creo que alguien quiera hecharse un clavado ahi

    o dime cual cres que pueda ser el error para que deba poner todo el codigo?

    incluso lo he ejecutado paso a paso y no funciona
    • Editado RHCRD martes, 21 de julio de 2015 23:56
    martes, 21 de julio de 2015 23:50
  • parece que tengo que eliminar el control y volverlo a agregar

    no se por que tengo que hacer eso

    miércoles, 22 de julio de 2015 0:27
  • Mira en ocasiones se corrompen los controles, a mi me ha pasado que eliminando el item y volviendo a agregarlo funca y no se ni porque se soluciona, posiblemente son bugs de asp. Asi que eso puede ser lo que paso

    Si mi respuesta fue útil ayudame marcándola como correcta.

    miércoles, 22 de julio de 2015 15:37