none
Problema de Conexion a BD Access RRS feed

  • Pregunta

  • Hola que tal me surge un problema, quiero usar el asistente para origen de datos de vb, selecciono BD despues->conjunto de datos->Nueva conexion->

    En origen de datos seleciono la opcion "Archivo de Base de Datos Microsoft Access"

    Nombre de Archivo de Base de datos "le doy examinar y selecciono mi BD"

    Usuario: Admin

    Contraseña: "mi password"

    y por ultimo le doy probar conexion y me dice que se realizó correctamente, hasta aho todo bien.

    despues elijo la tabla a cargar en mi data set

    seleciono y doy a finalizar, despues desde origenes de datos realizo una prueba de los datos que trae la consulta.

    obtengo los datos alojados en mi tabla de la BD

    por ultimo arrastro a mi form el dat grid para mostrar los datos.

     y cuando corro la aplicacion me sale que la ruta no es valida, debo recalcar que la ruta de mi bd es "C:\SAV\sav1.mdb"

    y el vb me muestra "C:\SAV\bin\Debug\sav1.mdb" 

    la verdad no tengo idea el porque de error, he estado tentado a realizar de nuevo la aplicacion, pero ya tengo varios modulos hechos me podrian ayudar? muchas gracias.



    domingo, 22 de abril de 2018 21:46

Respuestas

  • Por los síntomas que indicas, tiene pinta de que te ha generado en la conexión en una ruta relativa, y por eso te sale en el bin/debug al ejecutarlo. Busca dónde ha generado la cadena de conexión (probablemente en el app.config) y edítala y ponle la ruta absoluta del fichero .mdb.

    • Marcado como respuesta Rocko_star lunes, 23 de abril de 2018 17:50
    lunes, 23 de abril de 2018 7:24

Todas las respuestas

  • Por los síntomas que indicas, tiene pinta de que te ha generado en la conexión en una ruta relativa, y por eso te sale en el bin/debug al ejecutarlo. Busca dónde ha generado la cadena de conexión (probablemente en el app.config) y edítala y ponle la ruta absoluta del fichero .mdb.

    • Marcado como respuesta Rocko_star lunes, 23 de abril de 2018 17:50
    lunes, 23 de abril de 2018 7:24
  • Efectivamente, era la ruta, estaba otra ruta antes de la real, solo la borre y funciono, muchas gracias por el apoyo.
    lunes, 23 de abril de 2018 17:51