none
La barra de herramientas de Crystal Reports NO me funciona con ningun navegador en el ambiente de producción. RRS feed

  • Pregunta

  • Tengo una aplicacion web desarrollada con Visual Studio 2008 funcionando correctamente en Windows XP, incluyendo varios reportes de Crystal reports. recientemente instale la misma aplicación en un servidor virtual con Windows Server 2008 con intenciones de continuar el desarrollo y comenzar la producción de prueba. Toda la aplicacion funciona correctamente, menos el Web Report Toolbar en el entorno de producción. Al utilizar el navegador Motzilla Firefox al acercar el cursor a la barra de herramientas de Crystal Reports los iconos ahi mostrados se cambian al modo de texto y al hacer click busca el archivo

    http://miServidor/aspnet_client/System_Web/2_0_50727/CrystalReportWebFormViewer4/html/crystalexportdialog.htm

    y se me indica que éste archivo no se encuentra, aunque el archivo si existe (ya lo confirme). Al utilizar Windows Explorer la cosa está peor porque ni siquiera veo los iconos de la barra de crystal reports y mucho menos hacerles click.

    Ya instale el CR runtime que viene con mi version de Visual Studio, luego utilize el CR runtime ofrecido en la pagina web de SAP CR.

    Tengo CrystalDecisions.CrystalReports.Engine, Version=10.5.3700.0. Quiero pensar me me falta algun componente ó parche y estoy en la busqueda de una solución.

    Al no encontar respuesta a mi problema, he tenido que exportar mis reportes a pdf, y entonces por fin me funciona la impresión

    Seguramente algunos de ustedes han pasado por lo mismo, ojalá y puedan darme alguna orientación de que hacer, o donde buscar ó tendre que exportar mis reportes a pdf eternamente, o ya de plano comprar la licencia de SAP CR.

    Muchas Gracias.

     

















    jueves, 7 de julio de 2011 16:42