none
Seccion Detalles en Crystal Reports. RRS feed

  • Pregunta

  • Buenas, a ver si alguien me puede aconsejar.

     

    Debo hacer un informe que me imprima 3 tablas bastante grandes en Crystal Reports, las 3 tablas solo van a salir 1 vez, y sus datos se obtienen de una BB.DD Oracle,porque asi lo quiere el cliente.

    La Forma que he pensado de hacerlo es. Utilizar una cabecera fija, y en la sección detalle meter 3 subReports, cada uno con una de las 3 tablas super grandes, lo que me pasa es que cuando doy a la previsualizacion del informe, me aparece la cabecera pero las tablas han desaparecido, como es eso, alguien sabe si estoy haciendo algo mal??, creo que es porque las tabla o tablas no caben en una hoja y desaparecen :S , ya aviso las tablas son super grandes.

    A ver si alguien me puede aconsejar.

     

    Muchas Gracias, mis conocimientos de Crystal son limitados

    • Cambiado Enrique M. Montejo lunes, 25 de julio de 2011 17:51 Crystal Reports (De:Lenguaje VB.NET)
    viernes, 23 de abril de 2010 8:07

Todas las respuestas

  • hola

    estas conectando el reportes a un Dataset Tipado ?

    o sea cargas el dataset con los datos desde Oracle y estos los envias al reporte

     

    si es asi, y peinsas usar el reporte como un formulario, no como lista, podrias poner los subreprotes dentro del encabecado, o sea dejar de lado la seccion de Detalle alli no pongas nada ya que solo enviaras un solo registro de esta info, por ahi si en los subreprotes podrias usar el detalle, si es que hay mas de un dato

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    viernes, 23 de abril de 2010 12:41
  • Gracias Leandro.

     

    Son varias tablas muy grandes, (tipo excel) que solo van a salir una vez, las estoy colocando en la seccion detalles, añadiendo tantas secciones detalle como tablas hay, para que luego se puedan ocultar dependiendo de las que se quieran o no imprimir.

     

    Sabrias decirme porque cuando meto algo en un subreport y lo imprimo, me aparece una especie de link y no los datos que yo he escrito??

     

    Gracias.

    lunes, 26 de abril de 2010 13:35
  • hola

    mm es raro, la verdad nunca me paso, podrias subir un print screen del problema

    puedes ayudarte con el skydrive para subir las imagenes

     

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    lunes, 26 de abril de 2010 13:50