none
Insertar fórmula en celda de Excel. RRS feed

  • Pregunta

  • Hola a todos

    Con una pequeña app de consola exporto datos de sql a un archivo de excel pero tengo problemas cuando en determinadas columnas quiero poner fórmulas, en los casos de SUMA cuando abro el Excel me pone #NOMBRE; si me pongo en la barra de fórmulas y doy solo ENTER esta se evalúa correctamente. Este es mi código

    hoja.Cells(rowIndex + 2, 2) = "=SUMA(B3:B" & CStr(rowIndex + 1) & ")" '!ERROR
    hoja.Cells(rowIndex + 3, 2) = "=B10*1.5" 'SIN ERROR
    hoja.Cells(rowIndex + 4, 2) = "=SUMA(B3:B10)"  ' No la genero para probar y !ERROR

    Saludos



    domingo, 29 de abril de 2018 20:16

Respuestas