none
Problemas al configurar autenticacion por formularios RRS feed

  • Pregunta

  • Tengo configurado el web.config de la siguiente manera el cual saque de la guia de microsoft

    <authentication mode="Forms">
    <forms name=".ASPXFORMSDEMO" loginUrl="logon.aspx"
    protection="All" path="/" timeout="30" />
    </authentication>

    <authorization>
    <deny users ="?" />
    <allow users = "*" />
    </authorization>

    Y obviamente existe el webform logon.asp

    Cuando intento acceder a la pagina me tira el siguiente error

    Error de servidor en la aplicación '/'.

    Acceso denegado.

    Descripción: Error al obtener acceso a los recursos necesarios para completar esta solicitud. Puede que el servidor no esté configurado para obtener acceso a la dirección URL solicitada. 

    Mensaje de error 401.2.: No autorizado: error al iniciar sesión debido a la configuración de servidor. Compruebe que tiene permiso para ver este directorio o página con las credenciales que ha suministrado y los métodos de autenticación habilitados en el servidor Web. Póngase en contacto con el administrador del servidor Web para obtener más ayuda.


    Información de versión: Versión de Microsoft .NET Framework:4.0.30319; Versión ASP.NET:4.7.3429.0

    lunes, 19 de agosto de 2019 13:36

Respuestas

  • hola

    Sera que esta pregunta se relaciona con esta otra

    Metodos para autenticación



    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    • Marcado como respuesta Nestor Vitozzi lunes, 19 de agosto de 2019 20:48
    lunes, 19 de agosto de 2019 14:21
  • Gracias leandro, en parte lo solucione con el articulo que mencionas, pero seguia sin funcionar, pero en base a esto segui investigando y agregandole configuraciones al web.config, ahora funciona y me quedo de la siguiente manera:

        <authentication mode="Forms">
          <forms name=".ASPXFORMSDEMO" loginUrl="FLogin.aspx" defaultUrl="FMissocios.aspx" protection="All" path="/" timeout="30" />
        </authentication>    
        <urlMappings enabled="true">
          <add url="~/" mappedUrl="~/FLogin.aspx" />
        </urlMappings>
        <authorization>
          <allow roles="admin"/>
          <deny users="?" />
        </authorization>    

    Y afuera de system.web

     <location path="FLogin.aspx">
        <system.web>
          <authorization>
            <allow users="*" />
          </authorization>
        </system.web>
      </location>

    gracias por su aporte

    lunes, 19 de agosto de 2019 20:52

Todas las respuestas

  • hola

    Sera que esta pregunta se relaciona con esta otra

    Metodos para autenticación



    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    • Marcado como respuesta Nestor Vitozzi lunes, 19 de agosto de 2019 20:48
    lunes, 19 de agosto de 2019 14:21
  • Hola. Prueba a eliminar la parte de deny users de tu web.config y recompilar y volver a iniciar. Así verificamos que no haya otro problema subyacente

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó, vótala como útil. Saludos

    lunes, 19 de agosto de 2019 17:17
    Moderador
  • Gracias leandro, en parte lo solucione con el articulo que mencionas, pero seguia sin funcionar, pero en base a esto segui investigando y agregandole configuraciones al web.config, ahora funciona y me quedo de la siguiente manera:

        <authentication mode="Forms">
          <forms name=".ASPXFORMSDEMO" loginUrl="FLogin.aspx" defaultUrl="FMissocios.aspx" protection="All" path="/" timeout="30" />
        </authentication>    
        <urlMappings enabled="true">
          <add url="~/" mappedUrl="~/FLogin.aspx" />
        </urlMappings>
        <authorization>
          <allow roles="admin"/>
          <deny users="?" />
        </authorization>    

    Y afuera de system.web

     <location path="FLogin.aspx">
        <system.web>
          <authorization>
            <allow users="*" />
          </authorization>
        </system.web>
      </location>

    gracias por su aporte

    lunes, 19 de agosto de 2019 20:52