none
Error 413: Request Entity Too Large en peticiones a WCF para guardar archivos RRS feed

  • Pregunta

  • Hola disculpen, estoy tratando de insertar en una base de datos un archivo que pesa mas de lo que acepta que si no mal recuerdo son 40kb como petición; he configurado los config a nivel MVC, pero este a su vez realiza peticiones en un servicio WCF y recibo este error 413: Request Entity Too Large

    Si me pudieran ayudar a resolver que tengo que aumentar para que la peticion sea de archivos de hasta 20 mb.

    <?xml version="1.0"?>
    <configuration>
      <configSections>
        <section name="dataConfiguration" type="Microsoft.Practices.EnterpriseLibrary.Data.Configuration.DatabaseSettings, Microsoft.Practices.EnterpriseLibrary.Data, Version=5.0.414.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="true"/>
      </configSections>
      <dataConfiguration defaultDatabase="DesaServerAlt"/>
      <connectionStrings>
        <add name="DesaServerAlt" connectionString="Data Source=(local);Initial Catalog=Prueba;User Id=Prueba;Password=12345" providerName="System.Data.SqlClient"/>
      </connectionStrings>
      <appSettings>
        <add key="aspnet:UseTaskFriendlySynchronizationContext" value="true"/>
      </appSettings>
      <system.web>
        <compilation targetFramework="4.5" debug="true"/>
        <httpRuntime targetFramework="4.5"/>
      </system.web>
      <system.serviceModel>
        <bindings>
          <webHttpBinding>
            <binding name="myXmlHttpBinding" maxReceivedMessageSize="10485760" maxBufferSize="10485760">
              <readerQuotas maxDepth="2147483647" maxStringContentLength="2147483647" maxArrayLength="2147483647" maxBytesPerRead="2147483647" maxNameTableCharCount="2147483647"/>
              <security mode="None"/>
            </binding>
          </webHttpBinding>
        </bindings>
        <client>
          <endpoint address="" behaviorConfiguration="WebHttpBehavior" binding="webHttpBinding" bindingConfiguration="myXmlHttpBinding" contract="MassiveLoadProxy.IInvoiceMassiveLoad">
            <identity>
              <dns value="localhost"/>
            </identity>
          </endpoint>
        </client>
        <behaviors>
          <serviceBehaviors>
            <behavior>
              <!-- To avoid disclosing metadata information, set the values below to false before deployment -->
              <serviceMetadata httpGetEnabled="true" httpsGetEnabled="true"/>
              <!-- To receive exception details in faults for debugging purposes, set the value below to true.  Set to false before deployment to avoid disclosing exception information -->
              <serviceDebug includeExceptionDetailInFaults="false"/>
            </behavior>
          </serviceBehaviors>
        </behaviors>
        <protocolMapping>
          <add binding="basicHttpsBinding" scheme="https"/>
        </protocolMapping>
        <serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true"/>
      </system.serviceModel>
      <system.webServer>
        <modules runAllManagedModulesForAllRequests="true"/>
    
        <directoryBrowse enabled="true"/>
      </system.webServer>
    </configuration>
    Saludos 


    • Editado Rafiñña jueves, 26 de noviembre de 2015 6:39 Error al escribir
    jueves, 26 de noviembre de 2015 6:38

Respuestas

  • Modifica en tu web.config tanto de tu wcf como de tu aplicación web en lo siguiente

    https://msdn.microsoft.com/es-es/library/e1f13641(v=vs.100).aspx

    <httpRuntime targetFramework="4.5"
     maxRequestLength = "20000" />


    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó, vótala como útil. Saludos


    jueves, 26 de noviembre de 2015 11:41
    Moderador

Todas las respuestas

  • Hola. Ese error lo tienes al consultar un servicio WCF? 

    deberías mostrarnos los web.config tanto del servicio WCF como del cliente (tu aplicativo web)


    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó, vótala como útil. Saludos

    jueves, 26 de noviembre de 2015 8:30
    Moderador
  • Modifica en tu web.config tanto de tu wcf como de tu aplicación web en lo siguiente

    https://msdn.microsoft.com/es-es/library/e1f13641(v=vs.100).aspx

    <httpRuntime targetFramework="4.5"
     maxRequestLength = "20000" />


    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó, vótala como útil. Saludos


    jueves, 26 de noviembre de 2015 11:41
    Moderador