none
Problemas con scripts y el despliegue en el IIS RRS feed

  • Pregunta

  • Hola a todos, acabo de finalizar una aplicación desarrollada con Core 2.0, todo bien, dando trancazos logré publicarla en un IIS, todo bien, pero hay muchas vistas que tienen código script, esto no me esta funcionando, el ejemplo clásico del filtro Estados / Ciudades, donde tengo dos dropdownList, uno de los estados que llena al ingresar a la página y otro de cuidades que se llena al seleccionar un estado, si ejecuto el programa desde visual studio, todo funciona bien, pero cuando lo ejecuto desde el despliegue en el IIS, esos scripts no funcionan.

    Si alguien sabe al respecto se lo agradezco mucho.

    Miguel Lozada.

    jueves, 7 de febrero de 2019 19:19

Respuestas

  • hola

    Si ingresas al Developer tools del browser, accedes con F12, podrias ver en la solapa console si hay un error de javascript

    Quizas si estas minificando los .js puede causar algun problema

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    • Marcado como respuesta POS Services jueves, 11 de abril de 2019 13:01
    jueves, 7 de febrero de 2019 20:46

Todas las respuestas

  • hola

    Si ingresas al Developer tools del browser, accedes con F12, podrias ver en la solapa console si hay un error de javascript

    Quizas si estas minificando los .js puede causar algun problema

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    • Marcado como respuesta POS Services jueves, 11 de abril de 2019 13:01
    jueves, 7 de febrero de 2019 20:46
  • Hola Leandro en realidad había un error solo tenia que cambiar la posición del llamado de los script en el layout y funcionó.

    Gracias mi estimado.

    Miguel Lozada

    jueves, 11 de abril de 2019 13:02