none
Como se puede actualizar un TFS 2010 a TFS 2012 RRS feed

  • Pregunta

  • Hola quiero actualizar mi TFS 2010 a TFS 2012, pero me dice el instalador que primero tengo que desistalar el TFS 2010 antes de continuar. ¿No hay una forma de actualizar sin tener que desinstalar? Si no es el caso, ¿Como puedo desinstalar sin perder nada?
    viernes, 31 de agosto de 2012 10:09

Todas las respuestas

  • disculpen entonces...

    cuando instalo el TFS2012, los proyectos que estaban en el TFS2010 quedaron alojados en le TFS2012 sin ningun problema ???

    lunes, 11 de febrero de 2013 18:19
  • Si, cuando lances el instalador de VS2012 te pregunta si quieres utilizar una base de datos tfs existente, y así te convierte la antigua base de datos tfs2010 en tfs2012 y, siempre que no sea demasiado compleja, te funciona a la primera.

    Al menos a mi me ha funcionado correctamente.

    En mi web personal tengo un tutorial paso a paso desde un tfs11beta a un tfs2012, que es similar.

    lunes, 11 de febrero de 2013 19:59
  • Se desistala el TFS2010 sin tocar las bases de datos. Se instala el tfs2012 y se ubica las bases de datos del TFS2010. A mi me dio un problema con las cuentas de sharepoint, pero lo arreglé al meterme en la pantalla de administración del tfs y arle a aplicar cuentas de administrador otra vez. Después de eso todo OK.
    lunes, 11 de febrero de 2013 20:43
  • Estoy haciendo lo mismo que ustedes sugieren pero me salta el siguiente error
    miércoles, 27 de febrero de 2013 15:19
  • Por lo que leo en los mensajes no tienes los mínimos requisitos. La versión de SQL Server tiene que ser 2008 R2 SP1. Además cerciórate de que tienes un rol de administrador en SQL server que se llame serveradmin. 
    • Propuesto como respuesta Bnavarros lunes, 4 de marzo de 2013 12:08
    miércoles, 27 de febrero de 2013 15:39
  • Gracias y disculpa por la demora , de acuerdo a lo que tu dices , efectivamente necesitaba los permisos de admin y ya no me aparece el error tf255475 , pero trate de instalar los paquetes que me salen en el link del otro error y no puedo instalar la actualizacion... alguien sabe como solucionar el error TF400933

    Saludos


    • Editado Bnavarros jueves, 28 de febrero de 2013 15:46 mas detalles
    jueves, 28 de febrero de 2013 15:29
  • la solicion es bajar el SP1 de SQL Sever , verificar la configuracion regional (idioma tanto del SO, y el sql) , por ultimo bajar el package que indica el mensaje de error, reinciar la maquina y listo.

    Espero que a alguien mas le sirva

    Saludos

    lunes, 4 de marzo de 2013 12:08
  • Como te dije en la anterior, La versión de SQL Server tiene que ser 2008 R2 SP1 como mínimo...
    lunes, 4 de marzo de 2013 12:11