none
No consigo hacer funcionar el emulador RRS feed

  • Pregunta

  • Hola a tod@s,

    estoy con mis primeros pasos en la programación de aplicaciones para windows phone y como es habitual he empezado con el típico programita de hola mundo, pero al darle a F5 o a inicio me sale un mensaje de error que me dice "Error    1    El software Zune no está iniciado. Reinténtelo asegurándose de que dicho software está iniciado.",  antes de ese error me decía que no tenía el software de Zune por lo que me lo bajé, lo instalé e inicié sesión en él.  ¿Le ha pasado esto a alguien? ¿Alguien sabe qué está pasando?

    Gracias por vuestra ayuda. 

    martes, 25 de enero de 2011 13:59

Respuestas

  • Hola Estelarish

    Este error ocurre porque estás intentando ejecutar la aplicación en un dispositivo Windows Phone en vez de el Emulador.

    Para seleccionar el emulador en la barra de herramientas debes tener un desplegable donde te deja elegir entre Windows Phone 7 Device y Windows Phone 7 Emulator, si seleccionas emulador debería lanzarlo.

    Si esto no funciona, si que podrías probar a reinstalar las herramientas de desarrollo.


    MCTS .NET Framework 3.5 Windows Forms Application Development
    MCTS .NET Framework 3.5 Windows Presentation Foundation
    Visita mi Blog en Geeks.ms
    Sigueme en Twitter
    martes, 25 de enero de 2011 14:21
    Moderador

Todas las respuestas

  • Hola Eslelarish, has probado ha reinstalar las herramientas de desarrollo de Windows Phone ? desde este enlace te descargas un archivo que te lo instala todo

    http://download.microsoft.com/download/1/7/7/177D6AF8-17FA-40E7-AB53-00B7CED31729/vm_web.exe.

    Prueba a reinstlar, por cierto que Visual Studio tienes?, no habrás instalado el SP1?

     


    Oscar Alvarez Guerras - Arquitecto Software en I3B (I+D+I) Blog:http://geeks.ms/blogs/oalvarez Por favor marca como respuesta si te ha ayudado esta respuesta
    martes, 25 de enero de 2011 14:17
  • Hola Estelarish

    Este error ocurre porque estás intentando ejecutar la aplicación en un dispositivo Windows Phone en vez de el Emulador.

    Para seleccionar el emulador en la barra de herramientas debes tener un desplegable donde te deja elegir entre Windows Phone 7 Device y Windows Phone 7 Emulator, si seleccionas emulador debería lanzarlo.

    Si esto no funciona, si que podrías probar a reinstalar las herramientas de desarrollo.


    MCTS .NET Framework 3.5 Windows Forms Application Development
    MCTS .NET Framework 3.5 Windows Presentation Foundation
    Visita mi Blog en Geeks.ms
    Sigueme en Twitter
    martes, 25 de enero de 2011 14:21
    Moderador
  • Gracias bialguos por la rápida respuesta.  El enlace que me indicas es desde el cual me bajé la aplicación por lo tanto el Visual Studio es el Express que viene allí.

    Voy a desinstalar y a volver a instalar todo de nuevo a ver si así funciona.  Si funciona lo comunico para cerrar el post.

    martes, 25 de enero de 2011 14:23
  • Muchísismas gracias Josue, era eso.  Que duros son los comienzos  y por qué chorradas se queda una atascada:-)
    martes, 25 de enero de 2011 15:10
  • Gracias a ti! y animos, los comienzos son duros, pero aquí estamos la comunidad para ayudarte y el resultado vale la pena ;)
    MCTS .NET Framework 3.5 Windows Forms Application Development
    MCTS .NET Framework 3.5 Windows Presentation Foundation
    Visita mi Blog en Geeks.ms
    Sigueme en Twitter
    martes, 25 de enero de 2011 15:17
    Moderador
  • Josue,

    He leído la consulta de Estelarish que si bien es parecida no es lo mismo que me está sucediendo a mí...yo inicio el emulador, pero este queda como atascado en "..doing a complete OS boot.." y pasan más de 30 min y no responde a ningún comando de los botones (start, search, back). Que puede ser?


    Marcelo De Los Santos
    viernes, 4 de febrero de 2011 14:46
  • Hola creo que tu problema es que se ha corrompido el fichero. Donde el emulador guarda el estado estos ficheros se guardan en "%ALLUSERSPROFILE%\Microsoft\XDE Creo que tendrás que desinstalar y volver a instalar las herramientas de desarrollo para Windows phone para que quite los ficheros y se vuelvan a generar correctamente
    Oscar Alvarez Guerras - Arquitecto Software en I3B Blog:http://geeks.ms/blogs/oalvarez Por favor marca como respuesta si te ha ayudado esta respuesta
    viernes, 4 de febrero de 2011 15:10
  • Hola...he desistalado todo el paquete como sugerido y vuelto a instalar desde cero. Aún así, al ejecutar el emulador nunca sale del "Windows Phone Emulator is doing a complete OS boot". Que podría estar ocasionando eso? les comento que estoy ejecutando solamente el emulador, o es necesario ejecutar otra aplicación más a la vez? Como dato adicional, estoy usando una VM con W7 para el WP7. Saludos cordiales.
    Marcelo De Los Santos
    martes, 8 de febrero de 2011 16:47
  • Hola Marcelo el problema es que estas en una maquina virtual y el emulador es en si mismo una pequeña maquina virtual y ejecutar una maquina virtual dentro de otra hace que el rendimiento baje en picado e incluso te llegue a cascar, con lo que no te recomiendo que desarrolles en maquinas virtuales
    Oscar Alvarez Guerras - Arquitecto Software en I3B Blog:http://geeks.ms/blogs/oalvarez Por favor marca como respuesta si te ha ayudado esta respuesta
    martes, 8 de febrero de 2011 17:08
  • Gracias Oscar, tendré en cuenta tu sugerencia.

    Saludos cordiales.


    Marcelo De Los Santos
    martes, 8 de febrero de 2011 17:37