none
Error Inserción en modo Release RRS feed

  • Pregunta

  • Hola,

    Teniendo una estructura del estilo Cliente - Direcciones donde a cada Direccion se le asigna el ID de la Empresa a la que pertenece (es un ejemplo).

    Al generar mi proyecto y depurarlo en localhost (modo debug) al realizar un insert del cliente con sus direcciones asociadas a una empresa funciona correctamente y todas las claves foraneas se enlazan bien.

    Pero al publicar el proyecto en release al servidor final, esa misma query manda null en el campo empresaID de la Direccion y en consecuencia no las enlaza.

     

    Como digo el codigo es el mismo y manda cosas diferentes.

    Existe algun tipo de optimizacion al respecto y/o se puede deshabilitar?

    Uso EF4.0, .NET framework 4.0 con VS2010.

    Alguna idea?


    Vota mi respuesta si te ha sido útil. Gracias.
    miércoles, 4 de enero de 2012 11:27

Todas las respuestas

  • Hola,

    ¿Has comprobado que la base de datos del servidor final es la misma que la que has utilizado en el desarrollo? Por ejemplo que la relación Empresa-Dirección y las claves primarias sean iguales que en la base de datos de desarrollo.

     

    miércoles, 4 de enero de 2012 12:15
  • Hola David como te ha ido con tu problema??.. lo has logrado solucionar?

    Cuentanos.

    Saludos.


    Nicolás Herrera
    Bogotá - Colombia
    BLOG - Leader Group BogotaDotNet
    "Daría todo lo que sé, por la mitad de lo que ignoro." Rene Descartes
    viernes, 3 de febrero de 2012 2:47