none
Error al abrir el modelo en el Diseñador de modelos tabulares

    Pregunta

  • Buenos días a todos,

    Tengo Visual Studio 2015 en el cual creamos nuestros cubos tabulares desde una base de datos de SQL Server 2014.

    Tenemos creada una solución que incluye un cubo pero que a la hora de entrar en el diseñador me aparece este mensaje:

    ============================
    Mensaje de error:
    ============================
    
    Error del sistema:  Fuera del intervalo actual. 
    
    ----------------------------
    Error al abrir el modelo. Haga clic en Detalles para obtener más información.
    
    ============================
    Pila de llamadas:
    ============================
    
       en Microsoft.AnalysisServices.BackEnd.DataModelingServer.ExcecuteXMLA(String xmlaScript)
       en Microsoft.AnalysisServices.BackEnd.DataModelingServer.ExcecuteXMLA(String bismContent, String databaseName, Boolean isAlter)
       en Microsoft.AnalysisServices.BackEnd.DataModelingServer.CreateModelFromBimFile(String bismFileName, String databaseName)
       en Microsoft.AnalysisServices.VSHost.VSHostManager.HandleExistingProject(Boolean isImported, Boolean& isRefreshNeeded)
       en Microsoft.AnalysisServices.VSHost.VSHostManager.PrepareSandbox(Boolean newProject, Boolean& isRefreshNeeded, Boolean& isImpersonationChanged, Boolean& saveRequired, List`1& truncatedTables, Boolean isRealTimeMode, Int32 clientCompatibilityLevel)
    ----------------------------
       en Microsoft.AnalysisServices.VSHost.VSHostManager.PrepareSandbox(Boolean newProject, Boolean& isRefreshNeeded, Boolean& isImpersonationChanged, Boolean& saveRequired, List`1& truncatedTables, Boolean isRealTimeMode, Int32 clientCompatibilityLevel)
       en Microsoft.AnalysisServices.VSHost.Integration.EditorFactory.CreateEditorInstance(UInt32 grfCreateDoc, String pszMkDocument, String pszPhysicalView, IVsHierarchy pvHier, UInt32 itemid, IntPtr punkDocDataExisting, IntPtr& ppunkDocView, IntPtr& ppunkDocData, String& pbstrEditorCaption, Guid& pguidCmdUI, Int32& pgrfCDW)
    
    ============================

    Tan solo me pasa en este cubo, a otras personas de mi departamento les funciona bien (usan la versión Visual Studio 2014)

    Gracias de antemano.

    Un saludo.

    martes, 07 de noviembre de 2017 8:11

Todas las respuestas

  • ¿Visual Studio 2014? Me parece que te liaste. No se si puedes probar a importar desde el modelo tabular a tu visual studio. Si no te funciona prueba a reinstalarte las data tools de 2015 o puedes probar con las de 2017

    Comparte lo que sepas, aprende lo que no sepas (FGG)
    portalSQL
    El rincón del DBA

    martes, 07 de noviembre de 2017 12:04
    Moderador
  • Perdona, me refería a que mis compañeros tienen Visual Studio 2013 ud5 con DataTools.

    ¿Crees que si reinstalo las DataTools de 2015 o las de 2017 se solucionará el problema?

    martes, 07 de noviembre de 2017 13:02
  • lo mas probable es que sí, porque eso no tiene pinta mas que de un lio de instalaciones. Yo a veces trabajo con máquinas virtuales solo por eso. 

    Comparte lo que sepas, aprende lo que no sepas (FGG)
    portalSQL
    El rincón del DBA

    jueves, 16 de noviembre de 2017 7:51
    Moderador