none
Advertising en aplicación RRS feed

  • Pregunta

  • Buenas,

    estoy investigando cómo poner publicidad en una aplicación que quiero subir al market y me encuentro con post con instrucciones para wp 7.0 y no encuentro para 7.1 (Mango).  ¿Conocéis alguna guía fácil para seguir?

    Muchísimas gracias.

     

    miércoles, 14 de septiembre de 2011 22:45

Todas las respuestas

  • Buenas!

    En principio el tema de publicidad no ha cambiado entre 7.0 y 7.1, todo depende del proveedor de publicidad que uses. Yo le he echado un vistazo a Mobfox (http://www.mobfox.com) y tiene buena pinta, dice que paga un 300% más que el resto por CPM y paga en USA y Europa.

    Un  saludo!


    MCTS .NET Framework 3.5 Windows Forms Application Development
    MCTS .NET Framework 3.5 Windows Presentation Foundation
    Visita mi Blog en Geeks.ms
    Sigueme en Twitter
    jueves, 15 de septiembre de 2011 5:43
    Moderador
  • Gracias de nuevo Josue por tu ayuda.

    Te cuento, he probado lo del advertising con pubCenter y obtuve un Application ID y un Ad Unit ID, los cuales puse en el xaml en el cual quiero que aparezcan los anuncios.  Siguiendo las instrucciones que he visto por internet, he hecho lo siguiente:

    1.-  He añadido el namespace siguiente:

    xmlns:UI="clr-namespace:Microsoft.Advertising.Mobile.UI;assembly=Microsoft.Advertising.Mobile.UI"

    También he añadido las referencias correspondientes.

     

    2.-  Añadí el control de la siguiente manera:

    <UI:AdControl Name="nombre" ApplicationId="el número" AdUnitId="el otro número obtenido" Height="70" Width="480" VerticalAlignment="Bottom"  />

    Vi en las instrucciones que debía poner también   AdModel="Contextual", pero no me lo permite, me dice que esa propiedad no está en AdControl.

    Como no me funcionó esto fue cuando puse el post en el foro por lo que siguiendo tu consejo, me he registrado en MobFox y he hecho lo que te comento a continuación:

    1.- He añadido un siteApp de tipo wp7 y cuando me pide los detalles de la aplicación, le doy un nombre en site name, en Store URL no sé que poner, le he puesto la ruta donde se encuentra la aplicación en mi PC, he seleccionado una categoría y le he dado a continuar.  Una vez dada de alta, le he dado a “Request Activation” y hace un rato que me han comunicado el estado de “Approved”.

    2.- He añadido el control de la misma forma que te he comentado antes sólo que esta vez únicamente tengo un número por lo que he probado poniéndolo tanto en ApplictionId como en AdUnitId ya que ambas propiedades son requeridas.

    3.- Tanto en el primer intento como en este último, he puesto en la clase App.xaml.cs  AdControl.TestMode = false;  pero me informa que Microsoft.Advertising.Mobile.UI.AdControl no contiene una definición para TestMode. Así que lo he quitado.

    La aplicación funciona correctamente pero no aparece el banner de anuncios, sí lo hace en modo diseño pero no cuando se inicia la aplicación.

    ¿Se te ocurre qué puedo estar haciendo mal?

    Muchas gracias de nuevo y un saludo.

    jueves, 15 de septiembre de 2011 15:48
  • Sigo con este tema sin salirme de él :(

    He visto que he de poner lo siguiente en el código: 

    AdControl.TestMode = false;

    pero me sale el siguiente mensaje de error:

    Error    1    'Microsoft.Advertising.Mobile.UI.AdControl' does not contain a definition for 'TestMode'   

    Sigo los pasos según veo en las instrucciones de varias página.  Tengo puesto el using así como el namespace.  Incluso me he bajado un código de ejemplo que se supone que debería funcionar, pero ni esas.  El código me lo he bajado de aquí: http://blog.toetapz.com/page/3/

    ¿Alguna idea por aquí?

    Gracias y un saludo.

    domingo, 18 de septiembre de 2011 20:29
  •  

    Solucionado.  Hubo un cambio en el SDK en junio, me he desinstalado el que tenía instalado e instalado el nuevo SDK.

    Saludos.

    lunes, 19 de septiembre de 2011 9:05