none
Error de Reportes de Crystal Report en sistemas de 64 bits RRS feed

  • Pregunta

  • Saludos

    Tengo un sistema en VB. NET 2010 con Crystal Report sin embargo al instalar en Clientes con sistemas Windows 7 de 64 bits los reportes no funcionan, pero en Windows de 32 funcionan correctamente. En los sistemas de 64 bits instale los "CRRuntime_64bit_13_0_3.msi" pero sigue sin funcionar. Buscando por el foro encontré la descripción del problema en http://social.msdn.microsoft.com/Forums/es-ES/repdeves/thread/379acce0-95fc-4327-98f2-ea048bb241a4" pero no describen los problemas.

    Quería consultarles si existe alguna solución a parte de pedirle al cliente que formatee todas sus PC y reinstale SO de 32 bits.

    Gracias por la ayuda

    Atte.

    CarloCF

    jueves, 2 de mayo de 2013 17:09

Todas las respuestas

  • hola

    no evaluaste cambiar el proyecto para que compile a x86

    Platform Target

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina


    jueves, 2 de mayo de 2013 18:20
  • Saludos Leandro

    Gracias por tu tiempo en ayudarnos a todos.

    El proyecto se compila con CPU destino x86. Sin embargo falla. Compile a x64 pero me dio otro error de OleDB 4.0. ya que en el sistema utilizo datos locales con BD de Access 2010 de 32. Así que ahora debo resolver este error de OLDb. Ahora estoy bajando el Microsoft Access Database Engine 2010 Redistributable de x64 para probar.

    Este error lo informaron hace tiempo usuarios de VS2005 y pense que en esta version (2010) se habia solucionado.

    Terminando mis pruebas esta tarde volveré a comentar mis resultados.
    Gracias por tu interés
    Atte.
    CarloCF

    jueves, 2 de mayo de 2013 19:41
  • Saludos

    Después de 3 días de intentos no pude resolver el problema. Tengo una PC con Windows de 64bits, por un lado al instalar SQL Server Express x64 me da error al finalizar la instalación. Por otro lado al ejecutar el sistema compilado a x64 no reconoce el OLEDB 4.0, ni al instalar el archivo que debería resolverlo desde “http://www.microsoft.com/en-us/download/details.aspx?id=13255”. Según la información disponible Microsoft.Jet.OleDB.4.0 no funciona en plataformas x64. Para que funcione Crystal en sistemas x64 debo compilar a x64 pero este no reconoce el acceso a Access. ¿Alguna sugerencia?

    Gracias por la ayuda

    domingo, 5 de mayo de 2013 15:03
  • alguno de estos dos links te puede ayudar en tu problema del Microsoft.Jet.OleDB.4.0

    link 1

    link 2

    instala en tu maquina de pruebas Microsoft.Jet.OleDB.12.0 para ver si te funciona y resuelve tu problema de acces, esto se debe a que en tu conexion pones Microsoft.Jet.OleDB.4.0 cuando debe ser Microsoft.Jet.OleDB.12.0, saludos.


    si mi respuesta te ayudo votala como util, si resolvio tu duda marcala como respuesta, de esta manera ayudas a otros compañeros que tengan dudas similares.

    martes, 7 de mayo de 2013 18:29