none
Subir Proyecto ASP.NET a Windows Plesk RRS feed

  • Pregunta

  • Hola amigos del foro.

    estoy haciendo una pequeña aplicación web que el cual tiene un login.aspx que esta soportado por un control login de visual studio 2015. trate de configurar la pagina de asp en la pestaña Configuración ASP. Pero ya no existe desde la versión Visual studio 2012.

    Busque por google y pude echar a correr la perstaña Configuración ASP con el siguiente método.

    Pantalla CMD.

    iisexpress.exe /path:C:\Windows\Microsoft.NET\Framework\v4.0.30319\ASP.NETWebAdminFiles /vpath:"/asp.netwebadminfiles" /port:34163 /clr:4.0 /ntlm

    http://localhost:34163/asp.netwebadminfiles/default.aspx?applicationPhysicalPath=C:\miapp&applicationUrl=/

    Ahí configure los usuario y roles de la aplicación y todo bien.

    Pero ahora deseo subirlo a un hosting web Windows plask  y la aplicación  funciona hasta el Login.aspx, sin embargo cuando intento logearme me aparece lo siguiente:

    Discúlpenme si no fui muy claro.

    muchas gracias.


    Saludos desde Chile.


    miércoles, 24 de febrero de 2016 14:35

Respuestas

  • ok pero sigues sin mencionas que es la pestaña "Configuración ASP" te refieres ?

    en el config veo un connection string, pero no sabria decirte si los datos que alli defines son correctos

    el dato del "Data Source" lo validaste con el proveedor del hosting ?

    saluds


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    • Marcado como respuesta Aprendiz_Chile miércoles, 24 de febrero de 2016 19:02
    miércoles, 24 de febrero de 2016 16:42

Todas las respuestas

  • hola

    >>trate de configurar la pagina de asp en la pestaña Configuración ASP.

    no entendi, de que pestaña "Configuración ASP" te refieres ?

    apuntas a configurar asp.net membership con las pantallas de WAT (ASP.NET Web Site Administration Tool)

    >>sin embargo cuando intento logearme me aparece lo siguiente:

    pero alli el error es de conexion a la db, como defiens el connection string a la base de datos ?

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    miércoles, 24 de febrero de 2016 15:41
  • Gracias por responder.

    mira esta es la configuración de mi web.config en Visual studio 2015.

    <configuration>
    	<appSettings>
    		<add key="ValidationSettings:UnobtrusiveValidationMode" value="None"/>
    		<add key="miapp"/>
    	</appSettings>
    	<system.web>
    		<roleManager enabled="true"/>
    		<authentication mode="Forms"/>
    		<compilation debug="true" strict="false" explicit="true" targetFramework="4.5.2">
    			<assemblies>
    				<add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
    	</assemblies>
    		</compilation>
    		<httpRuntime targetFramework="4.0.30319"/>
    	</system.web>
    	<system.webServer>
    		<validation validateIntegratedModeConfiguration="false"/>
    	</system.webServer>
    	<system.web>
    		<authorization>
    			<deny users="?"/>
    		</authorization>
    	</system.web>
    </configuration>

    y asi es como queda en el Hosting:

    <configuration>
      <appSettings>
        <add key="ValidationSettings:UnobtrusiveValidationMode" value="None" />
        <add key="miapp" />
      </appSettings>
      <system.web>
        <roleManager enabled="true" />
        <authentication mode="Forms" />
        <compilation strict="false" explicit="true" targetFramework="4.5.2">
          <assemblies>
            <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
          </assemblies>
        </compilation>
        <httpRuntime targetFramework="4.0.30319" />
        <globalization culture="es-CL" uiCulture="es-CL" />
      </system.web>
      <system.webServer>
        <validation validateIntegratedModeConfiguration="false" />
      </system.webServer>
      <system.web>
        <authorization>
          <deny users="?" />
        </authorization>
      </system.web>
      <connectionStrings>
        <remove name="LocalSqlServer" />
        <add name="LocalSqlServer" connectionString="Data Source=db.win6.sintetix.com;Initial Catalog=sequelme_;User ID=Usuario;Password=xxxx" />
      </connectionStrings>
    </configuration>


    Saludos desde Chile.


    miércoles, 24 de febrero de 2016 16:15
  • ok pero sigues sin mencionas que es la pestaña "Configuración ASP" te refieres ?

    en el config veo un connection string, pero no sabria decirte si los datos que alli defines son correctos

    el dato del "Data Source" lo validaste con el proveedor del hosting ?

    saluds


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    • Marcado como respuesta Aprendiz_Chile miércoles, 24 de febrero de 2016 19:02
    miércoles, 24 de febrero de 2016 16:42
  • Esta es la pestaña a la cual me refiero.

    Y si acabo de corregir el Data Source.

    <!--
      For more information on how to configure your ASP.NET application, please visit
      http://go.microsoft.com/fwlink/?LinkId=169433
      -->
    <configuration>
      <appSettings>
        <add key="ValidationSettings:UnobtrusiveValidationMode" value="None" />
        <add key="miapp" />
      </appSettings>
      <system.web>
        <roleManager enabled="true" />
        <authentication mode="Forms" />
        <compilation strict="false" explicit="true" targetFramework="4.5.2">
          <assemblies>
            <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
          </assemblies>
        </compilation>
        <httpRuntime targetFramework="4.0.30319" />
        <globalization culture="es-CL" uiCulture="es-CL" />
      </system.web>
      <system.webServer>
        <validation validateIntegratedModeConfiguration="false" />
      </system.webServer>
      <connectionStrings>
        <remove name="LocalSqlServer" />
        <add name="LocalSqlServer" connectionString="Data Source=198.49.219.220,2880;Initial Catalog=sequelme_;User ID=Usuario;Password=*****" />
      </connectionStrings>
    </configuration>

    miércoles, 24 de febrero de 2016 16:54
  • Muchas gracias.

    El tema pasaba por la cadena de conexión ene l web config estaba mala, estaba apuntando hacia otro lado.


    Saludos desde Chile.

    miércoles, 24 de febrero de 2016 19:02