Error 10644 while Creating a new VM from a template - SCVMM 2007 R2 SP1


  • I have been struggling with this for about a full day.  Between uninstalling and reinstalling things and searching the internet; this has been extremely frustrating.

    The error appears to happen when it is creating the Virtual Floppy Disk that has the Answers file on it.

    My Target Host is a Quad Processor Opteron system (64bit), my SCVMM Server is a 64bit Server.  my Desktop from where I am using the admin console is a 64bit windows machine.

    The Template is that of a 64bit Windows 2008 server, with just a bare bones operating system.

    I verified that I have the correct WAIK installed - It is version 6.0.6001.18000, 64bit version located in c:\Program Files\Windows AIK\Tools\Image Manager

    I checked, all of the assemblies (.dll files) are present in the GAC with the same version

    I read a post somewhere that someone was able to achieve success but copying the directory into the c:\program files\microsoft system center virtual machine manager 2008 r2\bin directory.  I tried it, there is no different in behavior.

    I tried creating a new Template, no change in behavior.

    I made sure that the Group Policy was setup so that I could have a blank administrator password.  No change in behavior.

    I have looked through the eventlog, which is littered with useless messages about jobs starting, completing and in my case this one is failing, but there is no specific indication as to EXACTLY what the error was that caused the failure.

    I used Sysinternals to determine whether there were any noticeble errors during the activity, I did not see any.

    I am out of ideas, and need someone to point me in a direction to try to determine what the cause could be.

    martes, 30 de agosto de 2011 6:01

Todas las respuestas

  • Finally Figured it out.  After more searching, I found this link:


    It is a utility that you can run on the various machines to capture a log of what the problems are.


    My logs show this error:

    0DC4.1A44::08/30-06:15:15.928#15:UnattendXMLFile.cs(780): System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.ComponentStudio.ComponentPlatformInterface, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified. 
    File name: 'Microsoft.ComponentStudio.ComponentPlatformInterface, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35' 
    at Microsoft.VirtualManager.WorkloadCreation.UnattendXMLFile..ctor(String path, Version osVersion, Architecture arch, ProductType ptype) 
      at Microsoft.VirtualManager.WorkloadCreation.UnattendXMLFile.CreateUnattendXMLFile(String path, Version osVersion, Architecture arch, ProductType ptype) 

    At last... a meaningful clue... So I looked in the GAC, and sure enough, I had version 6.1xxxx of some of the WAIK assemblies, although I am not quite sure why since I let SCVMM install everything itself.  For those that are unsure how to fine the GAC, you can look in c:\windows\Assembly to see everything that is installed, and you can right-click individual ones and uninstall them. Simply dragging the new ones into that directory will install them.

    Anyway, I uninstalled the offending DLLs, and re-registered the ones that were 6.0 in the GAC, and now it is working.



    martes, 30 de agosto de 2011 6:45
  • Not sure if you are still monitoring this thread, but where did you get the 6.0 dll's? I'm running into the exact same problem and I cannot get this to work at all. If I could find those DLL's I probably would be able to solve it. I've tried installing WAIK for Vista as well as 7 and I can't find the right versions of the dll's.


    Jeff Levinson | ALM MVP
    Author, "Software Testing with Visual Studio 2010"

    domingo, 01 de abril de 2012 0:58