none
Compatibilizar con CSS3 RRS feed

  • Pregunta

  • Me podéis decir que tengo que introducir en mi página para que sea el navegador que sea el que quiera ver mi página entienda el CSS 3, he oído que hay que hacer en la página a una librería que el navegador carga con la página pero no se cual es ni donde está, podéis indicarme algún enlace o algo que lo explique.

    un saludo y Gracias

    sábado, 8 de marzo de 2014 17:20

Respuestas

  • hay una librería que se llama modernizr, que te permite determinar por código si el navegador actual soporta o no soporta determinada función de html, javascript, o css. Pero si el resultado es que no soporta la funcionalidad deseada, es responsabilidad tuya el aportar una alternativa; modernizr no la provee de forma automática. En algunos casos lo que se hace es incluir alguna librería adicional que aporte la funcionalidad que falta (se conocen como "polyfills"), y en otros "degradar" el comportamiento de la página usando alguna otra presentación alternativa, aunque no sea tan bonita.

    http://modernizr.com/

    https://github.com/Modernizr/Modernizr/wiki/HTML5-Cross-Browser-Polyfills

    • Marcado como respuesta fjjcent miércoles, 12 de marzo de 2014 12:44
    sábado, 8 de marzo de 2014 20:11