none
Instalar SQL Server2008 R2 Express con Advanced Service en WXP virtualizado RRS feed

  • Pregunta

  • Buen dia.

    Instale SS2008 R2 Advance Service en en una maquina virtual con wpx sp3 se instalo corecto, pero a la hora de ir a ver los reportes en el navegador tanto Mozilla o IE pongo http://usuario-pc:8080/ReportServer_MPSQLEXPRESS, me pide usuario y contraseña es un problema que no puedo solucionar, decidi instalar nuevamente desde cero Wxp + SS2008 R2 Advance Service.

    La duda que tengo es cuando llego al punto de configurar el servidor, para cada servicio tengo que elegir una cuenta por lo general escojo servicio de red para todos los servicios y pongo el tipo de inicio en autamtico, talvez aqui esta mi problema que tipo de cuenta deveria escojer teniendo en cuenta que no pertenesco a ningun dominio y la maquina virtual no tiene IP

    Luego viene el modo de autenticacion siempre escojo el modo mixto en este punto no se si se generen los problemas.

    Mi pregunta que tipo de configuracion me recomiendan a la hora de instalar y luego la configuracion para Reporting Service.

    Hace algun tiempo instale la misma version de SS en W7 pero tengo el mismo problema ahora estoy retomando el tema.

    Agradesco su ayuda.

    Saludos.

    Mauricio Pulla.

    Cuenca-Ecuador.

    sábado, 12 de febrero de 2011 7:47

Respuestas

  • En cuanto a las cuentas de los servicios: con Servidio de Red debería funcionar. Aunque esta no es una configuración recomendada (por motivos de seguridad, ya que tiene más permisos de los necesarios), no es razón para que no te funcione Reporting Services. La recomendación es la de crear una cuenta de usuario normal, sin ningún privilegio especial (excepto que la contraseña no caduque), y durante la instalación asignar esa cuenta a los servicios. El proceso de instalación ya le asigna a la cuenta los permisos adecuados.

    En cuanto a configurar el servidor de base de datos con la autenticación en modo mixto, tampoco tiene por qué causar ningún problema.

    Lo que sí tienes que hacer durante la instalación es asignar una cuenta de usuario como administrador del motor de base de datos y como administrador de Reporting Services (el programa de instalación te la pregunta y no te deja seguir adelante si no asignas ninguna cuenta). Cuando accedas al Report Manager y te pida usuario y contraseña, tienes que introducir precisamente los datos de esa cuenta que asignaste durante la instalación. Una vez que accedas al report manager, si quieres puedes modificar los ajustes de seguridad y crear otras cuentas distintas.

     

    sábado, 12 de febrero de 2011 9:08
    Moderador

Todas las respuestas

  • En cuanto a las cuentas de los servicios: con Servidio de Red debería funcionar. Aunque esta no es una configuración recomendada (por motivos de seguridad, ya que tiene más permisos de los necesarios), no es razón para que no te funcione Reporting Services. La recomendación es la de crear una cuenta de usuario normal, sin ningún privilegio especial (excepto que la contraseña no caduque), y durante la instalación asignar esa cuenta a los servicios. El proceso de instalación ya le asigna a la cuenta los permisos adecuados.

    En cuanto a configurar el servidor de base de datos con la autenticación en modo mixto, tampoco tiene por qué causar ningún problema.

    Lo que sí tienes que hacer durante la instalación es asignar una cuenta de usuario como administrador del motor de base de datos y como administrador de Reporting Services (el programa de instalación te la pregunta y no te deja seguir adelante si no asignas ninguna cuenta). Cuando accedas al Report Manager y te pida usuario y contraseña, tienes que introducir precisamente los datos de esa cuenta que asignaste durante la instalación. Una vez que accedas al report manager, si quieres puedes modificar los ajustes de seguridad y crear otras cuentas distintas.

     

    sábado, 12 de febrero de 2011 9:08
    Moderador
  • Gracias Alberto.

    Instale nuevamente todo desde cero, asignandole un usuario normal pero dio problemas termine instalandole los servicios con la cuenta Servicio de Red. Al finalizar la instalacion la cambien el usuario administrador de Reporting Service el Usuario administrador del PC, no estoy en un dominio solamente estoy haciendo unas pruebas para el momento esta bien.

    Con IE puedo ver el acceder a la pagina de reportes y configuraciones pero con Firefox no puedo hacer, algo que se pueda hacer?

    Baje la base de datos de ejemplo de: Sample Databases for Microsoft SQL Server 2008R2 (SR1)  AdventureWorks2008R2_SR1.exe lo instalo al comenzar a con el tutorial de Reporting Service los nombres de campos o tablas no son los mismo, tengo que buscar y probar...

    Existe otra version de ejemplos donde las tablas coincida con el tutorial?

    Nuevamente gracias.

    Saludos.

    Mauricio Pulla.

    Cuenca-Ecuador

     

    lunes, 14 de febrero de 2011 14:59
  • Con IE puedo ver el acceder a la pagina de reportes y configuraciones pero con Firefox no puedo hacer, algo que se pueda hacer?

    Necesitarás que funcione la autenticación integrada de Windows (NTLM). En IE viene por defecto activada para los equipos de intranet y desactivada para internet. Yo no utilizo Firefox, así que no sé si viene activada o no, pero es muy posible que este tipo de autenticación venga por defecto desactivada y tengas que habilitarla desde alguno de los menús de opciones.

     

    miércoles, 30 de marzo de 2011 8:22
    Moderador
  • Gracias Alberto.

    voy a probar y luego te aviso.

     

    Saludos.

    Mauricio Pulla

    Cuenca-Ecuador

    jueves, 7 de abril de 2011 13:23