none
El primer informe que se invoca tarda mucho en presentarse RRS feed

  • Pregunta

  • En cualquiera de las versiones de Reporting Services (2005, 2008, 2008 R2, 2012) me he encontrado con el problema de que el primer infome que se invoca a través del reportviewer desde una aplicación .NET o desde SharePoint, en el caso de estar integrado con SharePoint, tarda mucho en ejecutarse y los demás ya no. Si se hace a través del portal de Reporting Services, lo que tarda es en presentarse la primera página del portal.

    ¿Hay alguna manera de solucionar este problema configurando de alguna manera el servidor de Reporting Services o el de SharePoint?

    Gracias por vuestra colaboración.

    sábado, 8 de febrero de 2014 19:35

Respuestas

  • Hola

    te comento como solucione esto cree un archivo .bat puedes investigar sobre ello en google, pero te explico a groso modo lo que es. Verás este archivo puede ejecutar aplicaciones, página de internet, etc. Este archivo no es más que un bloc de notas con extensión .bat en donde dentro de el yo coloque lo siguiente:

    start iexplore http://Nombre_Servidor/Reports/Pages/Folder.aspx

    lo único que debes hacer es ejecutar este archivo .bat para así levantar la Web del Reporting Services de manera que nadie se penalice con el primer ingreso


    Si se solucionó tu consulta no olvides marcar la respuesta de esta forma mantendremos el orden en el Foro.

    José Carlos Barba Gutierrez
    Lima - Perú
    Saludos

    lunes, 10 de febrero de 2014 15:56
  • Hola

    en el siguiente enlace se menciona lo que necesitas el porque de la lentitud en mostrar la primera página en sharepoint y una posible solución espero te sea de ayuda

    http://blogs.msdn.com/b/sofocle/archive/2012/07/24/sharepoint-still-slow-to-open-first-page-could-be-a-problem-with-microsoft-clr.aspx

    aún no he tenido la oportunidad de  tener un sharepoint por lo que no podría darte una solución a ello


    Si se solucionó tu consulta no olvides marcar la respuesta de esta forma mantendremos el orden en el Foro.

    José Carlos Barba Gutierrez
    Lima - Perú
    Saludos

    miércoles, 12 de febrero de 2014 19:27

Todas las respuestas

  • Hola

    te comento como solucione esto cree un archivo .bat puedes investigar sobre ello en google, pero te explico a groso modo lo que es. Verás este archivo puede ejecutar aplicaciones, página de internet, etc. Este archivo no es más que un bloc de notas con extensión .bat en donde dentro de el yo coloque lo siguiente:

    start iexplore http://Nombre_Servidor/Reports/Pages/Folder.aspx

    lo único que debes hacer es ejecutar este archivo .bat para así levantar la Web del Reporting Services de manera que nadie se penalice con el primer ingreso


    Si se solucionó tu consulta no olvides marcar la respuesta de esta forma mantendremos el orden en el Foro.

    José Carlos Barba Gutierrez
    Lima - Perú
    Saludos

    lunes, 10 de febrero de 2014 15:56
  • Hola José.

    Aprovechando la solución que has comentado, sabes si se puede aplicar algo similar para una aplicación de escritorio que tiene los reportes como locales y por último tengo formulada una pregunta te molestaría darle una leida para ver si tienes alguna solución su título es "Problemas con pie de grupo"

    Saludos

    lunes, 10 de febrero de 2014 19:58
  • Hola

    el archivo .bat puede ejecutar los .exe así que no habría problemas con hacerlo solo que deberás de investigar un poco que no creo te lleve más de unos minutos, ya que hay mucha información acerca de esto. 


    Si se solucionó tu consulta no olvides marcar la respuesta de esta forma mantendremos el orden en el Foro.

    José Carlos Barba Gutierrez
    Lima - Perú
    Saludos

    lunes, 10 de febrero de 2014 20:17
  • Hola José.

    ¿Dónde ejecutas el .bat?,

    ¿en el inicio de cada PC que se quiera conectar?,

    ¿en el servidor?,

    ¿cada cuánto tiempo lo ejecutas?

    Un saludo.

    miércoles, 12 de febrero de 2014 14:37
  • Hola

    lo ejecutarías en el servidor, ya que todos apuntan allí. Bueno lo deberías ejecutar cada vez que reinicies el servicio o reinicies el servidor


    Si se solucionó tu consulta no olvides marcar la respuesta de esta forma mantendremos el orden en el Foro.

    José Carlos Barba Gutierrez
    Lima - Perú
    Saludos

    miércoles, 12 de febrero de 2014 15:40
  • Gracias por la solución.

    En el cliente que estoy ahora mismo se usa SharePoint en lugar del portal del servidor de Reporting Services, y el problema es el mismo, el primer informe tarda mucho en comenzar a ejecutarse.

    ¿Cómo se haría en ese caso?

    Un saludo.

    miércoles, 12 de febrero de 2014 17:23
  • Hola

    en el siguiente enlace se menciona lo que necesitas el porque de la lentitud en mostrar la primera página en sharepoint y una posible solución espero te sea de ayuda

    http://blogs.msdn.com/b/sofocle/archive/2012/07/24/sharepoint-still-slow-to-open-first-page-could-be-a-problem-with-microsoft-clr.aspx

    aún no he tenido la oportunidad de  tener un sharepoint por lo que no podría darte una solución a ello


    Si se solucionó tu consulta no olvides marcar la respuesta de esta forma mantendremos el orden en el Foro.

    José Carlos Barba Gutierrez
    Lima - Perú
    Saludos

    miércoles, 12 de febrero de 2014 19:27