none
¿Con qué versión de MVC arrancar? RRS feed

  • Pregunta

  • Buenas!

    soy un programador de WebForms (2.0/3.5) tradicional, y quiero actualizarme, mi idea es empezar por asp.net MVC 4, pero es mejor empezar por la 3 para entender bien todo? o voy prácticando la 5?

    después iré profundizando con jQuery, las SPA, etc..

    gracias!

    lunes, 13 de julio de 2015 17:37

Respuestas

  • Hola Pedro Oscar,

    Yo te sugiero que inicies con la última versión de MVC ya que se introducen mejoras y sería bueno que si ya vienes relegado con el uso de ASP Net, no sigas relegandote mas con versiones anteriores de MVC. Sirve mucho la documentación oficial ASP NET MVC

    Si la solución propuesta atendió su consulta no olvide marcarla como respuesta.

    Willams Morales
    Arequipa - PERÚ

    • Marcado como respuesta Pedro Oscar lunes, 13 de julio de 2015 17:48
    lunes, 13 de julio de 2015 17:43

Todas las respuestas

  • Hola Pedro Oscar,

    Yo te sugiero que inicies con la última versión de MVC ya que se introducen mejoras y sería bueno que si ya vienes relegado con el uso de ASP Net, no sigas relegandote mas con versiones anteriores de MVC. Sirve mucho la documentación oficial ASP NET MVC

    Si la solución propuesta atendió su consulta no olvide marcarla como respuesta.

    Willams Morales
    Arequipa - PERÚ

    • Marcado como respuesta Pedro Oscar lunes, 13 de julio de 2015 17:48
    lunes, 13 de julio de 2015 17:43
  • gracias!
    lunes, 13 de julio de 2015 17:48
  • >>pero es mejor empezar por la 3 para entender bien todo? o voy prácticando la 5?

    no hay diferencia puedes empezar con la que mas guste porque ua sea que uses mvc 3, 4 o 5 todos implementan la arquitectura MVC de la misma forma

    aprenderlo en cualquier version sera lo mismo

    por supuesto de una version a otra hay algunas diferencias, pero si la idea es ir aprendiendo la base no cambia en nada

    igualmente particularmente recomendaria que si puede ser mvc 4 o superior mucho mejor

    a jquery la version que use no le afecta porque esta libreria ejecuta en el cliente, implementar SPA quizas cambie un poco porque esto se suele usar con Web Api

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina


    lunes, 13 de julio de 2015 18:56