none
Imagen no es desplegada cuando se utilizan HTML Entities RRS feed

  • Pregunta

  • Buenas tardes. Mi problema es el siguiente. Cuando coloco en mi archivo web html entities no me despliega la imagen, me despliega en el navegador:

    <img src="../Imagenes/Carrusel/Red_Apple.jpg" />
    &#60;img src=&quot;../Imagenes/Carrusel/Red_Apple.jpg&quot;&#62;
    <br />
    <img src="../Imagenes/Carrusel/Red_Apple.jpg" />

    No es igual que la segunda linea y debería mostrarme la imagen?

    Gracias

    martes, 28 de abril de 2015 19:31

Respuestas

Todas las respuestas

  • hola

    >>Cuando coloco en mi archivo web html entities

    que es un "html entities" ? que extension tiene el archivo es aspx o html

    >>No es igual que la segunda linea y debería mostrarme la imagen?

    la linea

    &#60;img src=&quot;../Imagenes/Carrusel/Red_Apple.jpg&quot;&#62;

    estas aplicando un encode al texto por lo que el browser no puede renderizarlo sino que lo muestra como texto

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    martes, 28 de abril de 2015 19:41
  • Leandro gracias por la respuesta. Ahora bien necesito mostrar la imagen asignandola desde c sharp y el mismo le aplica el encode. Entonces como puedo desde c sharp asignar esa imagen sin el encode. Gracias 
    martes, 28 de abril de 2015 19:50
  • hola

    porque no usas un <asp:Image> con un control de asp.net podrias asignar la url desde codigo c#

    si quieres un html entonces podrias ponerle el runat="server" y accederlo por el Id que le asignes

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    martes, 28 de abril de 2015 20:03
  • SI Leandro .. perfecto. Gracias
    • Marcado como respuesta nelson111 miércoles, 29 de abril de 2015 22:00
    miércoles, 29 de abril de 2015 22:00