none
SQL Server Reporting Services 2008: version Internet Explorer 10.0.11 con iframes problema de pintar el ancho RRS feed

  • Pregunta

  • Buenas:

    Con la actualizción de Internet Explorer 10 a  la versión 10.0.11,  cuando se pinta un reporting dentro de un iframe

    el estilo de width:100% no tiene efecto y pinta menos del 50% de ancho.  Este es el código que genera en HTML pero el width no tiene efecto.  Si se cambia a través de explorador a un valor por ejemplo de 900px, se amplia el ancho, pero con el 100% vuelve a encogerse y no hace el ancho real de la pantalla.

    <div id="ReportViewerControl_ctl09" style="width: 100%; height: 100%; overflow: auto; ;">

    Con la versión anterior de Internet Explorer 10.0.10 este problema no existía.

    Alguna idea de cómo solventarlo.

    Gracias y saludos,

    María Dolores

    lunes, 18 de noviembre de 2013 12:10

Respuestas

  • Hola

    entonces se puede decir que el problema es la versión del navegador te recomendarías retrocedieras a la versión del navegador que te permitía trabajar bien y esperar actualicen la actual versión del navegador, ya que no eres el único que tiene este inconveniente. Adicional si cuentas con sistema operativo licenciado sería bueno que no descargues las actualizaciones automáticamente.


    Si se solucionó tu consulta no olvides marcar la respuesta de esta forma mantendremos el orden en el Foro.

    José Carlos Barba Gutierrez
    Lima - Perú
    Saludos

    viernes, 22 de noviembre de 2013 14:40

Todas las respuestas

  • Más información sobre el problema:

    El problema es que el resporting genera este html con el    

    <div id="ReportViewerControl_ctl09" style="width: 100%; height: 100%; overflow: auto; ;">

    Y debería ser  absolute para que se pinte en toda la ventana. ¿ Hay algún modo de que el reporting no genere esos valores?

    Gracias y saludos,

    María Dolores

    martes, 19 de noviembre de 2013 16:13
  • me está borrando los valores este editor.  Aclarnado lo que no se ha borrado:

    está poniendo el estilo position   a relative   y debe estar absolute  para que funcione bien.

    martes, 19 de noviembre de 2013 16:15
  • Hola

    revisa el siguiente enlace

    http://stackoverflow.com/questions/2896362/ssrs-reportviewer-2010-iframe-ie-problem


    Si se solucionó tu consulta no olvides marcar la respuesta de esta forma mantendremos el orden en el Foro.

    José Carlos Barba Gutierrez
    Lima - Perú
    Saludos

    martes, 19 de noviembre de 2013 16:35
  • Buenas:

    El report siempre se ha pintado, el problema surge con esa versión concreta de Internet Explorer (10.0.11), donde la position  definida relative no la interpreta bien.  Con la versión 10.0.10  o 9 siempre ha ido bien, al igual que con otros navegadores que sigue yendo.  El resultado del reporting, es decir la tabla generada, es la que  deja a un 40% de amplitud y pinta un scroll horizontal.  La barra de opciones del reporting de parámetros o los botones para exportar sí que ocupan todo el ancho del navegador. Es sólo el resultado lo que se pinta mal.  Supongo que la única solución es retroceder la versión de Internet Explorer a la que funciona o cambiar a IE 11 que parece que ahí vuelve a ir.

    Gracias y saludos,

    María Dolores

    miércoles, 20 de noviembre de 2013 8:46
  • tienes activada la Vista de Compatibilidad?
    jueves, 21 de noviembre de 2013 9:36
  • Si cambio con F12 el modo Explorador a  Vista a Compatibilidad IE 10  o a IE 9 vuelve a ir bien. 
    viernes, 22 de noviembre de 2013 8:15
  • Hola

    entonces se puede decir que el problema es la versión del navegador te recomendarías retrocedieras a la versión del navegador que te permitía trabajar bien y esperar actualicen la actual versión del navegador, ya que no eres el único que tiene este inconveniente. Adicional si cuentas con sistema operativo licenciado sería bueno que no descargues las actualizaciones automáticamente.


    Si se solucionó tu consulta no olvides marcar la respuesta de esta forma mantendremos el orden en el Foro.

    José Carlos Barba Gutierrez
    Lima - Perú
    Saludos

    viernes, 22 de noviembre de 2013 14:40
  • Sugeriría meter en la página principal la típica etiqueta "META" que fuerza al Internet Explorer a funcionar en modo de compatibilidad, mientras no saquen una versión nueva de Reporting Services que sea compatible con el IE 10.0.11.

    martes, 3 de diciembre de 2013 20:21
    Moderador