none
‘Microsoft.ACE.OLEDB.12.0′ no está registrado en el equipo local. RRS feed

  • Pregunta

  • Cuando ejecuto mi aplicacion en otra pc me dice esto Microsoft.ACE.OLEDB.12.0 instale el office 2007 asta el AccesDatabaseEngine y sige saltando el mismo problema

    _V_:V__CV_

    miércoles, 24 de octubre de 2012 14:45

Respuestas

  • "MartinPrincip" escribió:

    > el problema es que no existen drivers de office 2007 para la plataforma
    > de 64-bits como puedo solucionarlo sin modificar el Software

    Pues muy fácil: instalando en los equipos cliente los Componentes redistribuibles de 64 bits del motor de base de datos de Microsoft Access 2010.

    Es decir, en lugar de instalar el "AccesDatabaseEngine" de Microsoft Office System 2007, instala el mismo archivo pero de Access 2010, ya que no existe una versión de 64 bits de AccessDatabaseEngine de Office System 2007.

    Si tienes alguna preocupación por modificar líneas de código de tu aplicación, te diré que no tienes que cambiar nada, ni la cadena de conexión con tu base de datos de Access, aunque ésta sea Access 2007, porque el proveedor OleDb sigue siendo el mismo: Microsoft.ACE.OLEDB.12.0.

    Un saludo


    Enrique Martínez
      [MS MVP - VB]

    Nota informativa: La información contenida en este mensaje, así como el código fuente incluido en el mismo, se proporciona «COMO ESTÁ», sin garantías de ninguna clase, y no otorga derecho alguno. Usted asume cualquier riesgo al poner en práctica, utilizar o ejecutar lo recomendado o sugerido en el presente mensaje.

    Si esta respuesta le ha resultado útil, recuerde marcarla como satisfactoria.

    Si usas Visual Basic .NET y deseas ser productivo y feliz, activa la instrucción Option Strict.





    miércoles, 24 de octubre de 2012 15:36
    Moderador

Todas las respuestas

  • de casualidad tu pc es de 64bits ?

    porque recuerda que el driver para conectarte con access no soporta los 64bits

    deberias cambiar

    imagen

    a x86 para que tenga compatibilidad con 32bits

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina

    miércoles, 24 de octubre de 2012 14:53
  • Me autorespondo : el problema es que no existen drivers de office 2007 para la plataforma de 64-bits como puedo solucionarlo sin modificar el Software

    _V_:V__CV_

    miércoles, 24 de octubre de 2012 14:54
  • compila con la platadorm x86

    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina

    miércoles, 24 de octubre de 2012 15:10
  • Compilo x86  y ejecuto en mi sistema de x64?

    _V_:V__CV_

    miércoles, 24 de octubre de 2012 15:16
  • "MartinPrincip" escribió:

    > el problema es que no existen drivers de office 2007 para la plataforma
    > de 64-bits como puedo solucionarlo sin modificar el Software

    Pues muy fácil: instalando en los equipos cliente los Componentes redistribuibles de 64 bits del motor de base de datos de Microsoft Access 2010.

    Es decir, en lugar de instalar el "AccesDatabaseEngine" de Microsoft Office System 2007, instala el mismo archivo pero de Access 2010, ya que no existe una versión de 64 bits de AccessDatabaseEngine de Office System 2007.

    Si tienes alguna preocupación por modificar líneas de código de tu aplicación, te diré que no tienes que cambiar nada, ni la cadena de conexión con tu base de datos de Access, aunque ésta sea Access 2007, porque el proveedor OleDb sigue siendo el mismo: Microsoft.ACE.OLEDB.12.0.

    Un saludo


    Enrique Martínez
      [MS MVP - VB]

    Nota informativa: La información contenida en este mensaje, así como el código fuente incluido en el mismo, se proporciona «COMO ESTÁ», sin garantías de ninguna clase, y no otorga derecho alguno. Usted asume cualquier riesgo al poner en práctica, utilizar o ejecutar lo recomendado o sugerido en el presente mensaje.

    Si esta respuesta le ha resultado útil, recuerde marcarla como satisfactoria.

    Si usas Visual Basic .NET y deseas ser productivo y feliz, activa la instrucción Option Strict.





    miércoles, 24 de octubre de 2012 15:36
    Moderador
  • Es el procedimiento adecuado, gracias
    jueves, 30 de agosto de 2018 23:37