none
request.GetResponse() no obtengo respuesta del servidor FTP RRS feed

  • Pregunta

  •  

    Estoy realizando un programa con visual C# para decargar ficheros via FTP. No tengo mucha idea sobre programación, pero encontre en internet la clase FtpWebResponse.

    Pero cuando ejecuto la orden:

    FtpWebResponse response = request.GetResponse() as FtpWebResponse;

    Stream responseStream = response.GetResponseStream();

     

    para obtener respuesta, se me queda esperando respuesta del servidor hasta que se desconecta y no se a que se debe.

    Utilizo en el servidor Filezilla Server y veo que me conecto remotamente con estas ordenes pero no consigo salir de ahí.

    Esto es lo q observo en el filezilla:

     

    (000001) 20/01/2009 17:00:24 - (not logged in) (xxx.xxx.xxx.xxx)> Connected, sending welcome message...

    (000001) 20/01/2009 17:00:24 - (not logged in) (xxx.xxx.xxx.xxx)>  220 Prueba conexion FTP

    (000001) 20/01/2009 17:00:24 - (not logged in) (xxx.xxx.xxx.xxx)> USER servidorprueba

    (000001) 20/01/2009 17:00:24 - (not logged in) (xxx.xxx.xxx.xxx)> 331 Password required for servidorprueba

    (000001) 20/01/2009 17:00:24 - (not logged in) (xxx.xxx.xxx.xxx)>  PASS ***********

    (000001) 20/01/2009 17:00:24 - servidorprueba (xxx.xxx.xxx.xxx)> 230 Logged on

    (000001) 20/01/2009 17:00:24 - servidorprueba (xxx.xxx.xxx.xxx)>  OPTS utf8 on

    (000001) 20/01/2009 17:00:24 - servidorprueba (xxx.xxx.xxx.xxx)> 200 UTF8 mode enabled

    (000001) 20/01/2009 17:00:24 - servidorprueba(xxx.xxx.xxx.xxx)>  PWD

    (000001) 20/01/2009 17:00:24 - servidorprueba(xxx.xxx.xxx.xxx)> 257 "/" is current directory.

    (000001) 20/01/2009 17:00:24 - servidorprueba (xxx.xxx.xxx.xxx)>  CWD /

    (000001) 20/01/2009 17:00:24 - servidorprueba (xxx.xxx.xxx.xxx)>  250 CWD successful. "/" is current directory.

    (000001) 20/01/2009 17:00:24 - servidorprueba(xxx.xxx.xxx.xxx)>  TYPE I

    (000001) 20/01/2009 17:00:24 - servidorprueba (xxx.xxx.xxx.xxx)> 200 Type set to I

    (000001) 20/01/2009 17:00:24 - servidorprueba (xxx.xxx.xxx.xxx)>  PASV

    (000001) 20/01/2009 17:00:24 - servidorprueba (xxx.xxx.xxx.xxx)>  227 Entering Passive Mode (172,xxx,xxx,xxx,4,66)

    (000001) 20/01/2009 17:00:45 - servidorprueba (xxx.xxx.xxx.xxx)> disconnected.

     

    Si alguien me puede decir a que se debe. O que respuesta espera del servidor?

    martes, 20 de enero de 2009 15:26

Respuestas