none
solucion al error Request Entity Too Large RRS feed

  • Pregunta

  • hola comunidad tengo el siguiente error Request Entity Too Large cuando envio a guardar dos imágenes, ya he tratado de resolver el error configurando el iis y configurando los servicios pero aun sigo con este error , alguien me podría ayudar


    Sergio Fernandez Cruz Life Run's of Code

    lunes, 22 de julio de 2013 19:32

Respuestas

  • Hola Sergio puedes cambiar en tu configuracion del web.config

    <system.web> 
            
    	 <httpRuntime maxRequestLength="524288" />
        </system.web>

    ???


    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    martes, 23 de julio de 2013 18:17
    Moderador

Todas las respuestas

  • Hola Sergio, puedes mostrar tus archivos de configuración tanto del servicio como del cliente?

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    lunes, 22 de julio de 2013 19:42
    Moderador
  • hola Sergio , este el webconfig :

    <?xml version="1.0"?>
    <configuration>
        <system.serviceModel>
          <services>
                          <service behaviorConfiguration="MYServiciosGeneralArsys" name="Arsys.ServiciosDistribuidos.ServiciosSociedadArsys">
              <endpoint binding="basicHttpBinding" bindingConfiguration="Binding1"
                name="ArsysSociedad" contract="Arsys.ServiciosDistribuidos.Servicios.IServiciosSociedadArsys" />
            </service>
             </services>
    
          <behaviors>
            <serviceBehaviors>
              <behavior name="MYServiciosGeneralArsys">
                <serviceMetadata httpGetEnabled="true" />
              </behavior>
              <behavior name="">
                <serviceMetadata httpGetEnabled="true" />
                <serviceDebug includeExceptionDetailInFaults="false" />
              </behavior>
            </serviceBehaviors>
          </behaviors>
    
          <bindings>
    
             <basicHttpBinding>
               <binding name="Binding1" maxBufferPoolSize="2147483647" maxBufferSize="2147483647"
                 maxReceivedMessageSize="2147483647" transferMode="StreamedRequest"
                 messageEncoding="Mtom">
                 <readerQuotas maxDepth="128" maxStringContentLength="2147483647"
                   maxArrayLength="2147483647" maxBytesPerRead="2147483647" maxNameTableCharCount="2147483647" />
                 <security mode="None">
                   <transport clientCredentialType="None" proxyCredentialType="None"
                     realm="" />
                   <message clientCredentialType="UserName" algorithmSuite="Default" />
                 </security>
               </binding>
             </basicHttpBinding>
           </bindings>
          <serviceHostingEnvironment multipleSiteBindingsEnabled="true" />
        </system.serviceModel>
        <system.web>
          <customErrors mode="Off"/>
          <compilation debug="true"
          targetFramework="4.0" />
          <globalization fileEncoding="utf-8"
              requestEncoding="utf-8"
              responseEncoding="utf-8"
              culture="es-CO"
              uiCulture="es-CO" />
        </system.web>
      </configuration>

    y este es el de App config:

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
      <system.net>
        <settings>
          <servicePointManager expect100Continue="false" />
        </settings>
      </system.net>
      <system.serviceModel>
        <bindings>
          <basicHttpBinding>
    <binding name="BasicHttpBinding_IServiciosSociedadArsys" maxBufferPoolSize ="2147483647" maxBufferSize ="2147483647" maxReceivedMessageSize ="2147483647" />
       </basicHttpBinding>
        </bindings>
     <client>
     <endpoint address="http://localhost:30584/Servicios/ServiciosSociedadArsys.svc"
            binding="basicHttpBinding" bindingConfiguration="BasicHttpBinding_IServiciosSociedadArsys"
            contract="ServiciosSociedadArsys.IServiciosSociedadArsys" name="BasicHttpBinding_IServiciosSociedadArsys" />
        </client>
      </system.serviceModel>
    </configuration>


     

    Sergio Fernandez Cruz Life Run's of Code

    lunes, 22 de julio de 2013 20:06
  • Donde tienes desplegado el servicio? En iis?

    Si es así revisa http://blogs.msdn.com/b/jiruss/archive/2007/04/13/http-413-request-entity-too-large-can-t-upload-large-files-using-iis6.aspx


    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    lunes, 22 de julio de 2013 20:17
    Moderador
  • los servicios están en el iis y aun asi no funcionan , ya aumente la cuota del iis y no funciona , probé también desde casini y nada , aun se sigue excepcionando.

    Sergio Fernandez Cruz Life Run's of Code

    lunes, 22 de julio de 2013 20:32
  • Prueba cambiando transferMode="StreamedRequest"
     de los binding a Streamed

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    lunes, 22 de julio de 2013 20:51
    Moderador
  • probé , lo que tu me dijiste y nada , sigue con el problema

    Sergio Fernandez Cruz Life Run's of Code

    lunes, 22 de julio de 2013 21:13
  • Configuraste también el app.config en los bindings como puse antes? Si es así creo que es tema del iis.

    Establece

    <location path="THENAMEOFTHESITEYOUHAVE" overrideMode="Allow">
       
    <system.webServer>
           
    <asp />
           
    <serverRuntime uploadReadAheadSize="2147483647" />
       
    </system.webServer>
    </location>

    En la configuración de tu iis


    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    lunes, 22 de julio de 2013 21:25
    Moderador
  • Hola Sergio puedes cambiar en tu configuracion del web.config

    <system.web> 
            
    	 <httpRuntime maxRequestLength="524288" />
        </system.web>

    ???


    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    martes, 23 de julio de 2013 18:17
    Moderador
  • te refieres al wbconfig del servicio o del servidor IIS?, lo cambien el webconfig del servicio y no funciono .


    Sergio Fernandez Cruz Life Run's of Code

    martes, 23 de julio de 2013 18:55
  • hola comunidad tengo el siguiente error Request Entity Too Large cuando envio a guardar dos imágenes, ya he tratado de resolver el error configurando el iis y configurando los servicios pero aun sigo con este error , alguien me podría ayudar


    Sergio Fernandez Cruz Life Run's of Code

    espero te sirva esta información.

    Yo la probe y ha funcionado.

    http://sistemas-ms2.blogspot.mx/2014/01/solucion-413-request-entity-too-large.html

    • Propuesto como respuesta Supermax55 viernes, 10 de enero de 2014 23:51
    viernes, 10 de enero de 2014 23:50
  • A mi me ha funcionado, gracias Sergio!!

    Ing. Lariza Anaya

    miércoles, 6 de noviembre de 2019 16:57