none
Error grave de compilacion para correr una aplicacion RRS feed

  • Pregunta

  • Hola buenos dias, estoy realmente frustado xq estoy tratando de correr una aplicacion ya hecha en .NET. El problema es q desde un principio la he podido probar y correr sin problemas hasta q x un momento empece a desarrollar un modulo para la aplicacion, dond logre desarrollar algunas vistas con sus logicas de negocio (archivos .aspx.vb) pero cuando comence a crear unas TableAdapter para hacer conexion con la base de datos y establecer mis sentencias sql, se me genero el siguiente error:

    Error de servidor en la aplicación '/Banesco_web'.

    Error de compilación
    Descripción:
    Error durante la compilación de un recurso requerido para dar servicio a
    esta solicitud. Revise los detalles de error específicos siguientes y modifique
    el código fuente en consecuencia.
    Mensaje de error del compilador: CS1502: La mejor coincidencia de método sobrecargado para
    'DataSetBanecoTableAdapters.tbbnc_procesoTableAdapter.Update(string, long, int)'
    tiene algunos argumentos no válidos
    Error de código fuente:   Línea 7389:       
    Línea 7390:        public virtual int Update(string proceso, long Original_idproceso) {
    Línea 7391:            return this.Update(proceso, Original_idproceso, Original_idproceso);
    Línea 7392:        }
    Línea 7393:    }
    Archivo de
    origen: c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET
    Files\banesco_web\d5a4be37\c668351f\App_Code.uyhqbyrp.0.cs

    El detalle es que ese metodo y ese archivo dond me sale el error, yo nunca lo codifique, es decir me parece que es un error generado de configuracion, y mas grave aun cuando intento corregir el error, o sencillamente documento esa linea, al correr nuevamente la aplicacion me aparece exactamente el mismo error pero en otro archivo que pareciera que se generara  cada vez que intento de nuevo generar la aplicacion y por la tanto cada vez que corrijo el error me aparece nuevamente un archivo App_Code con otra extension....xfavor lo que quisiera es encontrar alguna manera si existe desde visual studio de borrar toda la aplicacion y generarla nuevamente desde cero para que me pueda correr ya que previamente si me corria perfectamente, que hago para resolver este problema?? xfavor ayudenme c los agradezco, Gracias...
    jueves, 27 de agosto de 2009 13:48

Todas las respuestas

  • Hola, puede ser que haya desarrollado en el modulo nuevo algun metodo que choca con uno actual.

    la pregunta es esta usando clase parciales?

    ademas esta consulta no deberia ir en esta categoria. deberia ser ASP.NET

    Cualquier cosa avisa!


    Developer
    jueves, 27 de agosto de 2009 20:10